locked
Can't create Team Project with MS Scrum v1.0 process template RRS feed

  • Question

  • I can't create a team project

    with SCrum v1.0 process template. The project creation wizard had problems while uploading documents to the server. Furthermore, in the error log it says (some parts are translated from german):

    Module: WSS
    Exception Message: TF249033:
    The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033. (Typ TeamFoundationServerException)

       at Microsoft.TeamFoundation.Client.SharePoint.SharePointTeamFoundationIntegrationService.HandleException(Exception e)
       bei Microsoft.TeamFoundation.Client.SharePoint.SharePointTeamFoundationIntegrationService.CreateSite(String webApplicationUrl, String absolutePath, String title, String description, UInt32 localeId, String template, Boolean templateIsTitle, String ownerLogin, String ownerName, String ownerEmail, Guid configurationServerId, Guid projectCollectionId)
       bei Microsoft.TeamFoundation.Client.SharePoint.WssUtilities.CreateSite(ICredentials credentials, Uri adminUrl, WssSiteData siteCreationData, Guid configurationServerId, Guid projectCollectionId)
       bei Microsoft.TeamFoundation.Client.SharePoint.WssUtilities.CreateSite(WssSiteData siteCreationData, TeamProject settings)
       bei Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.CreateSite(WssSiteData siteCreationData, WssCreationContextWrapper contextWrapper)
       bei Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.HandleSiteCreation(WssCreationContextWrapper contextWrapper, XmlNode taskNode)

    Inner Exception details:

    Exception Message: TF249033: The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033. (Typ SoapException)SoapException-Details: <detail exceptionType="TeamFoundationServerException" />


    I also installed the WSS 3.0 language pack - still the same problem. What can I do here?

    p.s.: However, creation of team projects with the agile process template is working fine.

    best regards,

    Pete


    "veritas vos liberabit"
    Monday, August 9, 2010 2:10 PM

Answers

  • I found these lines in the Log above:

    The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033.

    Since I am running all English versions I am not that familiar with these kind of problems. However the reason might might be that you are running a German WSS?


    Tomas Scott
    Tuesday, August 10, 2010 5:53 PM

All replies

  • I suggest you have a look in the SharePoint log files (%CommonProgramFiles%\Microsoft Shared\web server extensions\12\LOGS) that are generated when you execute the operation?

     As a suggestion try running the following from a command prompt just before and just after you execute the command:

     net stop sptrace && net start sptrace

     This will force SharePoint to start a new log file each time so the contents will be scoped to your operation (and you won't have to look through so many entries).

    I had some problems with the creation, and it turned out to be a permission issue, even though I was able to create projects with the Agile Template.

    Good Luck!

    /Tomas


    Tomas Scott
    Monday, August 9, 2010 2:17 PM
  • Thanks for your ideas Tomas,

     

    here's the interesting part of the log:

     

    #20009: Can't open folder "xml" [Translated from german (Kann Ordner "xml" nicht öffnen)]
    (#3: Can't open folder "xml" [Translated from german (Kann Ordner "xml" nicht öffnen)])	 
    Unknown SPRequest error occurred. More information: 0x81070209	 
     Exception Message: Exception from HRESULT: 0x81070209 (type SPException)  Exception Stack Trace:  at Microsoft.SharePoint.Library.SPRequest.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.SPSite.GetWebTemplates(UInt32 LCID)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetSiteTemplateName(Uri siteUrl, String templateTitle, UInt32 lcid, Boolean byTitle)  Inner Exception Details:  Exception Message: Exception from HRESULT: 0x81070209 (type COMException)  Exception Stack Trace:  at Microsoft.SharePoint.Library.SPRequestInternalClass.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.Library.SPRequest.GetWebTemplates(UInt32 lcid) 	 
     Exception Message: TF249033: The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033. (type TeamFoundationServerException)  Exception Stack Trace:  at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetSiteTemplateName(Uri siteUrl, String templateTitle, UInt32 lcid, Boolean byTitle)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.<>c__DisplayClass30.<CreateSite>b__2c()   at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)   at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)   at Microsoft.Share	24e7ff2f-c353-4ab9-a9e6-24f86b1a2445
    Point.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)   at Microsoft.TeamFoundation.SharePoint.WssUtil.RunAnonymousMethod(ElevationType elevateType, CodeToRunElevated code)  Inner Exception Details:  Exception Message: Exception from HRESULT: 0x81070209 (type SPException)  Exception Stack Trace:  at Microsoft.SharePoint.Library.SPRequest.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.SPSite.GetWebTemplates(UInt32 LCID)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetSiteTemplateName(Uri siteUrl, String templateTitle, UInt32 lcid, Boolean byTitle)  Inner Exception Details:  Exception Message: Exception from HRESULT	24e7ff2f-c353-4ab9-a9e6-24f86b1a2445
    : 0x81070209 (type COMException)  Exception Stack Trace:  at Microsoft.SharePoint.Library.SPRequestInternalClass.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.Library.SPRequest.GetWebTemplates(UInt32 lcid) 	24e7ff2f-c353-4ab9-a9e6-24f86b1a2445
     Exception Message: TF249033: The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033. (type TeamFoundationServerException)  Exception Stack Trace:  at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetSiteTemplateName(Uri siteUrl, String templateTitle, UInt32 lcid, Boolean byTitle)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.<>c__DisplayClass30.<CreateSite>b__2c()   at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)   at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)   at Microsoft.Share	1eab0fe3-b3ed-46f0-b271-f75ef426c26e
    Point.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)   at Microsoft.TeamFoundation.SharePoint.WssUtil.RunAnonymousMethod(ElevationType elevateType, CodeToRunElevated code)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.CreateSite(String webApplicationUrl, String absolutePath, String title, String description, UInt32 localeId, String template, Boolean templateIsTitle, String ownerLogin, String ownerName, String ownerEmail, Guid applicationInstanceId, Guid projectCollectionId)  Inner Exception Details:  Exception Message: Exception from HRESULT: 0x81070209 (type SPException)  Exception Stack Trace:  at Microsoft.SharePoint.Library	1eab0fe3-b3ed-46f0-b271-f75ef426c26e
    .SPRequest.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.SPSite.GetWebTemplates(UInt32 LCID)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetSiteTemplateName(Uri siteUrl, String templateTitle, UInt32 lcid, Boolean byTitle)  Inner Exception Details:  Exception Message: Exception from HRESULT: 0x81070209 (type COMException)  Exception Stack Trace:  at Microsoft.SharePoint.Library.SPRequestInternalClass.GetWebTemplates(UInt32 lcid)   at Microsoft.SharePoint.Library.SPRequest.GetWebTemplates(UInt32 lcid) 	1eab0fe3-b3ed-46f0-b271-f75ef426c26e
    CreateSite END 00000000-0000-0000-0000-000000000000; [SPWebApplication: http://mytfsserver/; Caller: mytfsserver\Administrator]	 
    GetWebIdentifier BEGIN /websites/Sandbox/TFS; [SPWebApplication: http://mytfsserver/; Caller: mytfsserver\Administrator]	 
    Exception Message: TF250025: The following URL does not point to a valid SharePoint site: http://mytfsserver/websites/Sandbox/TFS. Verify that you have the correct URL and that it points to a SharePoint site. (type TeamFoundationServerException)  Exception Stack Trace:  at Microsoft.TeamFoundation.SharePoint.UrlInfo.Initialize(SPWebApplication webApp, String absolutePath, Boolean expectToExist)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.<>c__DisplayClass11.<GetWebIdentifier>b__e()   at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)   at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)   at Mi	10f7eba5-3b3e-4c88-a131-b6c6a9625016
    crosoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)   at Microsoft.TeamFoundation.SharePoint.WssUtil.RunAnonymousMethod(ElevationType elevateType, CodeToRunElevated code) 	10f7eba5-3b3e-4c88-a131-b6c6a9625016
    Exception Message: TF250025: The following URL does not point to a valid SharePoint site: http://mytfsserver/websites/Sandbox/TFS. Verify that you have the correct URL and that it points to a SharePoint site. (type TeamFoundationServerException)  Exception Stack Trace:  at Microsoft.TeamFoundation.SharePoint.UrlInfo.Initialize(SPWebApplication webApp, String absolutePath, Boolean expectToExist)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.<>c__DisplayClass11.<GetWebIdentifier>b__e()   at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state)   at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)   at Mi	1e8e72d9-b2b1-4ca4-99bb-a46b1a51f016
    crosoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)   at Microsoft.TeamFoundation.SharePoint.WssUtil.RunAnonymousMethod(ElevationType elevateType, CodeToRunElevated code)   at Microsoft.TeamFoundation.SharePoint.TeamFoundationIntegrationService.GetWebIdentifier(String absolutePath) 	1e8e72d9-b2b1-4ca4-99bb-a46b1a51f016
    GetWebIdentifier END 00000000-0000-0000-0000-000000000000; [SPWebApplication: http://mytfsserver/; Caller: mytfsserver\Administrator]	 
    An SPRequest object was not disposed before the end of this thread. To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it. This object will now be disposed. Allocation Id: {EC4FE813-A261-4305-9F1D-0A86B2030D27} To determine where this object was allocated, create a registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\HeapSettings. Then create a new DWORD named SPRequestStackTrace with the value 1 under this key.	 
    
    

     

    It says >>can't open folder "xml"<< (maybe in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE)

    I also read a post in a msdn forum that I should copy the content from the 1033 folder in the 1031 folder. But there is only a 1031 folder in the path above.

     

    thanks for your help

     

    Pete

     


    "veritas vos liberabit"
    Monday, August 9, 2010 2:39 PM
  • obviously, this is a error in the Windows Sharepoint Services (3.0) Module. Would it help if I uninstall WSS 3.0 and install Sharepoint Foundation 2010?

     

    best regards,

     

     

    pete


    "veritas vos liberabit"
    Tuesday, August 10, 2010 5:29 PM
  • I found these lines in the Log above:

    The site template is not available for the locale identifier (LCID). The site template name is: TFS2010 Agile Dashboard. The LCID is: 1033.

    Since I am running all English versions I am not that familiar with these kind of problems. However the reason might might be that you are running a German WSS?


    Tomas Scott
    Tuesday, August 10, 2010 5:53 PM
  • I see... So how about reinstalling an english version of WSS 3.0 or even Sharepoint Foundation 2010?

    Can I just install the other version and the TFS will still work after that or is there another procedure to reinstall WSS after TFS is already installed?

     

    best regards

     

    Pete


    "veritas vos liberabit"
    Tuesday, August 10, 2010 10:02 PM
  • I am sorry, but I am not sure about that. However I am pretty sure I heard that SharePoint Foundation 2010 had some problems, so I would not use that.

    By the way, did you install the WSS parts of the Scrum template? I have assumed you did. There is an instruction in the "Project Portal" folder.
    If you did not do that - try that first.
    With the conclusions from that task, you find that TFS makes use of Sharepoint solution packages. So reinstalling Sharepoint would most certainly mean you have to reinstall some TFS bits as well...
    Maybe, and I say maybe - an installation of WSS over the existing one might succeed...

    Good Luck!


    /Tomas


    Tomas Scott
    Wednesday, August 11, 2010 5:58 AM
  • I noticed that the "language" problem appeared on other paces too. So I gave up and reinstalled (nearly everything) on our server including , this time, an english version of Team Foundation Server 2010.

    Now the creation of projects with other templates like Scrum v1.0 or Scrum for TS works.

    Seems like there is a incompatibility problem with the use of a german TFS.

     

    thank you.

     

    best regards,

     

    Pete


    "veritas vos liberabit"
    Thursday, August 12, 2010 9:11 AM
  • If any of my comments were helpful to you you can mark them as Helpful - or even as answers...

    :-)

    Thanks!

     


    Tomas Scott
    Thursday, August 12, 2010 9:34 AM
  • Install a langage pack has not resolve the problem. I always the error message TF249033. Impossible to create a team project with the Microsoft Scrum Process template.

    In may case,  I deployed TFS2010 french on a single server with Windows Server 2008 R2 x64 French, SQL Server 2008 R2 x64 French, SharePoint Services 3.0 French and I installed the English language pack for SharePoint Services 3.0 + English Langage pack SP2.

    Is anyone have a solution ?

    Thanks.

    Thursday, December 23, 2010 3:40 PM
  • Hello

    I happen to the same trouble. I have Chinese TFS 2010 and Chinese SharePoint 2010. The problem is that Scrum 1.0 just publish the English version and its SharePoint Plugin references to the English version of SharePoint site template, TFS2010 Agile Dashboard. There are two solutions:

    1. Install the correct language pack of the TFS2010 Agile Dashboard site tempate on SharePoint

    2. Download the Scrum 1.0 process template(VS Menu > Team Explorer > Team Project Collection Settings > Process Template Manager > Select Scrum 1.0 and Download), locate the downloaded folder, edit wsstasks.xml in the Windows SharePoint Services folder, find <site template="TFS2010 Agile Dashboard" language="1033" /> and change 1033 to your lcid, for example, Simplified Chinese is 2052, finally upload the customized process template.

    Hope helpful.


    问题要简单,错误须详细@错误/异常/堆栈信息+操作系统+软件版本+all the context of the issue Hope Helpful | http://www.leoworks.net
    • Proposed as answer by Xiaofeng Wang Sunday, April 17, 2011 2:40 PM
    Sunday, April 17, 2011 2:40 PM
  • Hey Xiaofeng Wang

     

    You suggest to install the language Pack of TFS 2010 Agile Dashboard site template.

     

    Where can this be found?

     

    Regards

    Tuesday, May 10, 2011 8:19 AM
  • Read this blog http://learnsoftwareprocesses.com and solve all Scrum Problems
    Thursday, September 29, 2011 10:14 AM