none
MVMC Error message "The server failed to authenticate the request" RRS feed

  • Question

  • From: James @angriestjames via Twitter

    Are there known issues with the MVMC and Certificates? I can’t upload VM’s due to “Verify that the certificate is valid”

    I have ensure the cert is in both Personal and Trusted Root Auth stores.

    however the OS that I am using the MVMC on is Windows 10 will that make a difference?

    Thursday, March 10, 2016 11:43 PM

All replies

  • Hello,

    My goal is to convert some Vmware machines to Hyper-V to import them into Azure but am running into an issue.

    I followed the instructions (https://technet.microsoft.com/en-us/library/dn874004.aspx) and subsequent follow on links on certificate creation (I used two methods, ssh-keygen and makecert.exe) and uploading.

    I can see the cert in the "Management Certificates" section in the settings for Azure and the Thumbprint matches what is available on the machine with MVMC installed.

    It is present in both the Personal and Trusted Root Certification Authorities Stores for the Current User and the Thumbprints match (the keystore thumbprint has spaces where the uploaded one does not).

    Error remains, is there another way to get this done?

    I can provide details via screenshots once my account has been verified.

    Regards,

    James
    Friday, March 11, 2016 1:23 AM
  • MVMC is not supported on Windows 10 or Windows Server 2016. This may be your issue. Try to make the same operation from a supported OS, and then report the results.

    Windows Server 2008 R2 SP1, Windows Server 2012, Windows Server 2012 R2, Windows 8.1, or Windows 8.

    cmdlets function only on Windows Server 2012 R2, Windows Server 2012, Windows 8.1, or Windows 8.


    Regards, Samir Farhat || Datacenter Consultant || The way to share my knowledge with the community https://BuildWindows.wordpress.com

    • Proposed as answer by JameshNZ Wednesday, March 16, 2016 1:11 AM
    Friday, March 11, 2016 10:00 AM
  • Hi,

    Thank you for the response that certainly helped in the process.

    I switched back to Win2k12 server and had the same error until a re-generated the certificates with IIS on that version, perhaps a cert issue or versioning issue was at play here but I am now able to at least communicate with the Azure portal.

    However I cannot migrate my ESXi VM's, I have tried two, both Windows Servers and the same error for both "The entry 1 is not a supported disk database entry for the descriptor"

    Could this be a versioning issue with my ESXi host and the version of the VM's created?

    Wednesday, March 16, 2016 1:11 AM