none
I cannot type curly braces

    Question

  • Hello,

    I am just starting to learn C# . However, I am not able to type curly braces. How to do that?

    thank you in advance

    Friday, April 7, 2017 5:06 PM

All replies

  • What do you mean you can't type curly braces? Are you saying if you press { and } on the keyboard while in the editor of Visual Studio nothing happens?

    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Friday, April 7, 2017 5:11 PM
    Moderator
  • On most keyboards, the curly braces are upper case square brackets, [ and ]. Or the decimal ASCII codes for the curly braces are 123 and 125. They can be entered using the techniques documented here:

    https://msdn.microsoft.com/en-us/library/windows/desktop/gg153546(v=vs.85).aspx


    Richard Mueller - MVP Enterprise Mobility (Identity and Access)

    • Proposed as answer by Ryan Software Monday, April 10, 2017 4:55 PM
    Friday, April 7, 2017 5:17 PM
  • Hello,

    I really do not understand the problem. Can you explain ?

    You can use combination of altGr and the curly brace keys.

    Saturday, April 8, 2017 7:45 AM
  • Hi,

    I've had that problem a few times on my own. <g class="gr_ gr_6 gr-alert gr_gramm gr_run_anim gr_inline_cards Punctuation only-ins replaceWithoutSep" data-gr-id="6" id="6">Still</g> haven't figured out what seems to be the issue. Before doing this just make sure you accidently didn't change the keyboard mapping of windows environment (you can see down in <g class="gr_ gr_508 gr-alert gr_gramm gr_run_anim gr_inline_cards Style multiReplace" data-gr-id="508" id="508">your  windows</g> bar near the time). If you haven't changed, in your visual studio, go to Tools -> Options -> Environment -> Keyboard and hit the Reset button it will reset the keyboard mappings and possibly fix your problem.

    Hope this helps you solving you 

    Monday, April 10, 2017 10:07 AM