none
No updates to .net frameworks will install ...windows xp pro ...tried repair tool RRS feed

  • Question

  • Hi, Ive seen a few people with very similiar issues but want to be sure the fixes will work for me specifically since Ive learned from other forums which help with other problems (virus etc) ...they always say the info is intended for that specific person alone because one difference can ruin you ...so please excuse my not trying everything Ive found on my own  :)

    This was a new install of xp pro & person taking care of this was no longer able to continue so I may simply be near the beginning of their .net frameworks installing process?  I tried several times to install required updates and all non-frameworks install fine ...but these have errors stating it failed.  There are processes running constantly which I found are installer related - two instances of msiexec.exe & a dotnetfx35_x86.exe - which look to be related?  as was the error message at one point- "microsoft .net services Installation Utility has encountered a problem and needs to close"  error 0x0000005.   There are also shortcuts on the desktop of fixdotnet (2) & a microsoft fixit . 

    Only .nets with sp1 are installed (or look to be in 'add remove programs')  since the validation tool I tried shows MANY errors and cannot do what is needed to fix this.   Im pretty good at following direction but no wiz by any means ...so while following, I may ask questions which seem ridiculous to the experienced ...you may need a little patience  :)   Any help appreciated ,Thanks all...  cat


    • Edited by catzs Friday, July 26, 2013 6:49 AM spell
    Thursday, July 25, 2013 8:17 AM

Answers

All replies

  • First, is the Windows XP fully up to date (SP3 and subsequent patches)?

    Next, let's find out exactly which .NET versions are on the system.

    Use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with the highest available .NET Framework version selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Once you provide the information requested above, further suggestions can be made.

    Thursday, July 25, 2013 2:02 PM
  • I dont know if it is up to date but Ive downloaded any updates that are found.  How do I find this info?I did run the validation tool, heres the info 1st and last 15.  I wont be available until this evening to check back in so dont feel you are ignored  :)   Thanks

    *Where I underlined 'For more Info info' below ...it wouldnt allow links so here are the 'SEE' articles/links   microsoft kb 2698555 & link ID 246062

     [07/25/13,12:32:02] Beginning of new SetupVerifier activity logging session
    [07/25/13,12:32:02] Activity log file location: C:\DOCUME~1\SCARED~1\LOCALS~1\Temp\setupverifier_main_07-25-13_12.32.02.txt
    [07/25/13,12:32:02] Error log file location: C:\DOCUME~1\SCARED~1\LOCALS~1\Temp\setupverifier_errors_07-25-13_12.32.02.txt
    [07/25/13,12:32:02] Build created on September 10, 2012
    [07/25/13,12:32:02] Detected operating system: Windows XP (x86)
    [07/25/13,12:32:02] For more information about repairing the .NET Framework, see  [07/25/13,12:32:02] Install state for .NET Framework 1.0: not installed.
    [07/25/13,12:32:02] Install state for .NET Framework 1.1: installed with service pack 1.
    [07/25/13,12:32:02] Install state for .NET Framework 2.0: installed with service pack 1.
    [07/25/13,12:32:02] Install state for .NET Framework 3.0: installed with service pack 1.
    [07/25/13,12:32:02] Install state for .NET Framework 3.5: not installed.
    [07/25/13,12:32:02] Install state for .NET Framework 4 Client: not installed.
    [07/25/13,12:32:02] Install state for .NET Framework 4 Full: not installed.[07/25/13,12:32:02] Install state for .NET Framework 4.5: not installed.
    [07/25/13,12:32:02] Windows directory: C:\WINDOWS   

    [07/25/13,12:33:17] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [07/25/13,12:33:17] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [07/25/13,12:33:17] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [07/25/13,12:33:17] ExecutablePath = 'Netfx20TestApplication.exe'
    [07/25/13,12:33:17] FriendlyName = '.NET Framework 2.0 test application'
    [07/25/13,12:33:17] TimeoutSeconds = '300'
    [07/25/13,12:33:17] WaitOnExit = 'true'
    [07/25/13,12:33:17] Silent = 'true'
    [07/25/13,12:33:17] Launching process 'Netfx20TestApplication.exe' now
    [07/25/13,12:33:17] Process successfully launched. Waiting 300 seconds for it to complete.
    [07/25/13,12:33:18] Process 'Netfx20TestApplication.exe' exited with return code 0
    [07/25/13,12:33:18] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [07/25/13,12:33:18] File C:\WINDOWS\system32\netfxperf.dll (version 1.1.4322.573) is installed on the system
    [07/25/13,12:33:18] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [07/25/13,12:33:18] Verification succeeded for product .NET Framework 3.0 SP1


    • Edited by catzs Thursday, July 25, 2013 5:07 PM added info
    Thursday, July 25, 2013 4:45 PM
  • 'I dont know if it is up to date but Ive downloaded any updates that are found."

    Lets assume you're up to date.

    To finish updating .NET 2.0 and 3.0, plus install .NET 3.5, run this cumulative installer:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    To install .NET Framework 4.0, use this:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    If either install fails, provide complete logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Saturday, July 27, 2013 9:12 PM
  • Sorry for the delay, I was having sign-in issues for the site

    OK ...I ran the 1st install twice and 2x it said there is already an instance of this tool running.  I checked tasks & saw one dotnetfx along with a few msie.exe or something as I stated initially.
    I ended the dotnetfx one & tried again.  Immediately an error window stating the utility experienced
    problems, has to close.
    Meanwhile the page showing download said completed and went to the insatll page.
    Took a long time & now all the green bands are filled in across the board but going nowhere?
    It wont even close when I hit the 'X'
    I ran the collection tool twice also and that seems to just quit without warning and dissapear.
    How do I get to the file you had said the log (if it exists)  I dont think it worked but I'll check
    Also I dont have any public accounts to just send a link.  Other suggestions if the log was created?
    Thanks 

    Monday, July 29, 2013 3:57 AM
  • "How do I get to the file you had said the log (if it exists)  I dont think it worked but I'll check"

    Search your C drive with Windows Explorer (make sure to include hidden and systems files in the search) for vslogs.cab.

    You already have a Windows Live ID you use in these forums, so you have a free SkyDrive account as well:

    http://windows.microsoft.com/en-US/skydrive/download

    Monday, July 29, 2013 3:54 PM
  • I downloaded skydrive and think I got the folder correctly into the public viewing area.
    here is the link

    hmmm, wont let me put in a link so just add

    https skydrive dot live dot com with the following:

    ?cid=5a528a7f83857449#cid=5A528A7F83857449&id=5A528A7F83857449%21105

    hope this does it  :)  Thanks for your patience!!

    • Edited by catzs Tuesday, July 30, 2013 4:19 AM added link removed link
    Tuesday, July 30, 2013 4:14 AM
  • It appears that your XP is not up to date.

    "Windows XP Service Pack 2"

    Please install Service Pack 3 for Windows XP and subsequent updates.

    http://support.microsoft.com/kb/322389/en-gb

    Your Windows Installer (v3.1) is also out of date. You need to install v4.5:

    http://support.microsoft.com/kb/942288?wa=wsignin1.0

    Until your XP is up to date, you will not receive important updates through Windows Update and will not be able to install newer software.

    Wednesday, July 31, 2013 1:52 PM
  • I tried installing the SP3 as you suggested.  When it was restarting though a page was displayed which said there was a problem possibly with new hardware, power failure etc but Im sure it was the installation.

    It gave choices of starting in 'normal' , 'last known good configuration' & safe modes (networking etc)  I tried normal first- wouldnt take ...then last known good configuration still no go & would repower over again with each but stopped at that screen.

    I tried just repowering and came back to the same page of choices which at that point I decided I had to do a system restore so i entered safe mode and went back to before the install.  I dont know if there would be any log telling what the problem was so let me know if there is somewhere to look?  ...btw, I did turn off firewall but not my PC Tools security program.  Hope I didnt make things worse?!  Sorry if so...

    The installer gave too many choices & without knowing which exactly I needed, decided that after the SP3 I shouldnt guess for fear a a real mess  :)   Any suggestions appreciated,  cat      



    • Edited by catzs Thursday, August 1, 2013 5:32 AM
    Thursday, August 1, 2013 5:25 AM
  • The issues you are having with SP3 for XP lead me to believe that you have OS problems that need the attention of XP experts.

    In your situation, I would format the OS partition and reinstall the OS from scratch, then apply all updates to XP before installing any other software.

    As my brute force approach may well not be something you want to do, I suggest you contact the XP experts, here:

    http://answers.microsoft.com/en-us/windows/forum/windows_xp-windows_install?tab=QnA&status=all&mod=&modAge=&advFil=&postedAfter=&postedBefore=&tm=1375451653263

    for more sophisticated solutions.

    Friday, August 2, 2013 1:55 PM