locked
Visual Studio axml editor no longer shows resources RRS feed

  • Question

  • User25561 posted

    Hi,

    I recently updated to the latest Xamarin SDK 4.20.0.37 (full version details below) as well as Android SDK Tools 24.1.2, Platform Tools 22 and Build tools 22.

    All of a sudden when I edit axml files, no images/resources load. My custom theme doesn't appear in the Theme dropdown and if I browse for an image with the Project Resources window, it's completely empty.

    It's almost like none of my resources can be found.

    If I run the project though and send it to the emulator it works just fine. So it's just the axml editor that's having problems.

    This doesn't seem to be just my project, if I create a blank Android project from scratch, I get exactly the same behaviour. It seemed to occur just after updating to the latest Android and Xamarin SDKs.

    A quick look at the logs shows a lot of: ERROR: Bridge [resources.format] Failed to convert @drawable/IconNext into a drawable

    Please help, this has really killed my speed of development!

    I've attached the Xamarin Logs and here are the version details:

    Microsoft Visual Studio Professional 2012 Version 11.0.61030.00 Update 4 Microsoft .NET Framework Version 4.5.51641

    Xamarin 3.9.483.0 (978be3d) Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

    Xamarin.Android 4.20.0.37 (9e05e39f02bafe8fc0b7ab025d99f3b446835ad4) Visual Studio plugin to enable development for Xamarin.Android.

    Xamarin.iOS 8.8.0.0 (702be5207a1446b066f4653f68739da13c045227) Visual Studio extension to enable development for Xamarin.iOS.

    Xamarin.iOS Unified Migration 1.0 Automated migration for Xamarin iOS Classic projects to Unified

    Thursday, March 19, 2015 3:41 AM

All replies

  • User25561 posted

    Tried reinstalling the latest over the top, same result.

    Installed Xamarin.VisualStudio_3.9.302.msi and it's fixed the problem.

    I'm going to have to downgrade everything so I can get back up and running.

    Thursday, March 19, 2015 7:16 AM
  • User772 posted

    Same problem for me. Xamarin have a 100% record of breaking something on every release!

    Thursday, March 19, 2015 5:07 PM
  • User25561 posted

    Xamarin have a 100% record of breaking something on every release!

    Ain't that the sad truth :neutral:

    Friday, March 20, 2015 12:06 AM
  • User3066 posted

    Same here... is there any Xamarin guy out there?

    Friday, March 20, 2015 5:13 PM
  • User3066 posted

    Opened a bug submission here: https://bugzilla.xamarin.com/show_bug.cgi?id=28248

    Friday, March 20, 2015 6:04 PM
  • User25759 posted

    Thank you for opening bug.

    Simple work around currently is to install: 3.9.347: http://download.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_3.9.347.msi

    This is only 1 version back. You do not need to go back to 3.9.302

    To see change log of what is new in the .483 release see: http://developer.xamarin.com/releases/vs/xamarin.vs3/xamarin.vs3.9/

    On the mac for iOS you would need to revert back to 8.6.3 for compatibility currently for the build host. http://download.xamarin.com/MonoTouch/Mac/monotouch-8.6.3.3.pkg

    This will remove watchkit support from VS.

    Friday, March 20, 2015 6:40 PM
  • User25759 posted

    Update: This is fixed in the next Alpha release, which should be out soon.

    Friday, March 20, 2015 7:06 PM
  • User116538 posted

    Today I've tried with alpha release, but nothing happened. I'm working with Xamarin Studio for Mac + MvvmCross. It seems for me like system fails parsing Android platform resources, because I can see only few string resources from Android package.

    Tuesday, March 24, 2015 7:33 AM
  • User105864 posted

    Downgrade to http://download.xamarin.com/studio/Mac/XamarinStudio-5.7.2.7-0.dmg solved my problem

    Tuesday, March 24, 2015 12:32 PM
  • User53531 posted

    I switched the tools folder android sdk location. The old will name toolss now so u can rename back to tools that will solve the axml problem.

    Friday, March 27, 2015 8:23 PM