none
S3 batch script problem RRS feed

  • Question

  • Hi,

      •    I have a package which I setup to invoke a batch script which uses Amazon's Cloud. Now when I run the package, no problems. I get a file named null with the number of records affected and a second file with the bucket name and the data. Now if I setup a batch file which runs dtexec, again no problems. If I schedule the package using the SSIS proxy or using the batch script and use CmdExec and I use Credentials and Proxies based off my user account. The null file will toggle between 0 and 1 k and it always lists these wierd dlls it says are missing if I stop it. Here is an example: Msg 4860, Level 16, State 1, Server IP-0A52355E, Line 1
        Cannot bulk load. The file
        "D:/import/WinFxCustomControlTemplateWizard.dll" does not exist.

     

    My batch script looks like this and am using Execute Process task:


    @ECHO OFF
    cd D:\import
    ERASE /Q d:\import\*
    d:\Ankur\s3.exe get %1/%2/*
    for %%X in (*) do (osql.exe -S d2.internal.acompany.com -U aUser -P aPassword -o "d:/import/null.txt" -Q "DECLARE @bulk_cmd varchar(1000); SET @bulk_cmd = 'BULK INSERT [%3].[dbo].[%4] FROM ''D:/import/%%X'' WITH (ROWTERMINATOR = '''+CHAR(10)+''',FIELDTERMINATOR = ''\t'', MAXERRORS=100)' ;EXEC(@bulk_cmd)")

    Any help appreciated,

    Regards,

    Bryan

    Tuesday, August 28, 2012 9:49 PM

All replies

  • are you sure that the user account that you created proxy for it have enough permission ? I mean permission to files, database that you are trying to do bulk insert.

    http://www.rad.pasfu.com

    Tuesday, August 28, 2012 9:57 PM
    Moderator
  • It's my own account I'm using as the proxy at least for testing. I can run the batch file interactively and it works fine. I run it under the credential and I get the error mentioned above. I tried adding s3 to my path variable, thinking it was maybe searching for the executable. However that didn't change anything. Not sure why it is giving me this error?

    Thanks again,

    Bryan

    Wednesday, August 29, 2012 2:01 PM