none
.Net Framework 4 fails to install on Vista x86 Home Premium SP2 RRS feed

  • Question

  • On my computer running a 32-bit Vista Home Prenium SP2 OS, I have attempted to install .Net Framework 4 several times already. 

    Here is my logfile:

     

    Exe (F:\133bc79ddf638077a0dd450b\SetupUtility.exe) succeeded.
    [2/7/2011, 20:12:50]Exe Log File: dd_SetupUtility.txt
    [2/7/2011, 20:12:50] Action complete
    [2/7/2011, 20:12:50]Helper item execution succeed.
    [2/7/2011, 20:12:50]Delaying for Starting to delay
    [2/7/2011, 20:12:51]WU Service was already enabled or was running
    [2/7/2011, 20:12:51]WU Service: EnsureWUServiceIsNotDisabled succeeded
    [2/7/2011, 20:12:51] Action: Performing Action on Exe at F:\133bc79ddf638077a0dd450b\Windows6.0-KB956250-v6001-x86.msu...
    [2/7/2011, 20:12:51]Launching CreateProcess with command line = wusa.exe "F:\133bc79ddf638077a0dd450b\Windows6.0-KB956250-v6001-x86.msu" /quiet /norestart
    [2/7/2011, 20:12:51]Exe (F:\133bc79ddf638077a0dd450b\Windows6.0-KB956250-v6001-x86.msu) failed with 0x652 - Another installation is already in progress. Complete that installation before proceeding with this install. .
    [2/7/2011, 20:12:51]PerformOperation on exe returned exit code 1618 (translates to HRESULT = 0x652)
    [2/7/2011, 20:12:51] Action complete
    [2/7/2011, 20:12:51]Error 1618 is mapped to Custom Error: Retry
    [2/7/2011, 20:12:51]Retry 3 of 3 of custom error handling
    [2/7/2011, 20:12:51]Retry count over existing limit, not going to retry again.
    [2/7/2011, 20:12:51]OnFailureBehavior for this item is to Rollback.
    [2/7/2011, 20:12:51] Action: Performing actions on all Items...
    [2/7/2011, 20:12:51] Action complete
    [2/7/2011, 20:12:51] Action complete
    [2/7/2011, 20:12:51]Final Result: Installation failed with error code: (0x00000652), "Another installation is already in progress. Complete that installation before proceeding with this install. " (Elapsed time: 0 00:06:11).

    Due to the fact that the installer would freeze on my previous installation attempts, I was forced to terminate it with task manager. I am still not sure why the installation failed the first time that I tried, however. After reading several other threads, I have a feeling that my error could be caused by the "Windows6.0-KB956250-v6001-x86.msu" file. 

    Please advise me on how to correct this issue. It's quite frustrating that some of my software isn't working due to this.

    Thanks in advance,
    Wesley

     

    Tuesday, February 8, 2011 2:46 AM

Answers

  • Based on your description, it seems that your issue might not be related with installation. Your OS is Windows Vista, please check the following suggestions first and check whether your issue was solved after each step.

    1.       Please disable anti-virus software or other security software and try it again.

    2.       Please disable UAC and try it again.

    3.       Please right click installer and run it as Administrator and try it again.

     

    Furthermore, please download Collect tool to collect installation log files if you have any issue during installation.

     

    If you have any findings, please feel free to let me know.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Larcolais Gong Saturday, February 19, 2011 3:25 AM
    Wednesday, February 9, 2011 11:11 AM