locked
Lots of green underlining after upgrade RRS feed

  • Question

  • User882043084 posted

    Hi, 

    Since upgrading from VS2010 to VS2013 I'm getting a lot of green underlinging (warnings) of markup code.  The message says that known elements (content,  DropDownList etc) are not known elements when obviosly they are,  or that there might be a problem with the web.config which there is not. 

    This just happened a few moments ago when no changes had been made to markup.  

    I would just ignore this but it stops intelli-sense from working. Frown

    Any ideas? 

     

    Monday, December 2, 2013 3:30 AM

Answers

  • User-718146471 posted

    Take a look here: http://social.msdn.microsoft.com/Forums/vstudio/en-US/086495fd-2383-44b6-b4cb-89dfb3576f9e/visual-studio-2013-intellisense-issues?forum=visualstudiogeneral

     

    Hi Paul,
    
    Thank you for posting in the MSDN forum.
    
    Just to make this issue clearly, what kind of app are you developing? Whether all projects have the same issue? 
    Would you mind sharing me a simple sample? So I could repro this issue in my side with VS2013 RC. If it is related to the language developing like VC# app, you could check the setting under
    TOOLS->Options->Text Editor->the specific language(C#) ->IntelliSense. I have met a similar issue, the IntelliSense doesn’t work, but it works well after I reset my VS settings. TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”
    ->Choose a Default Collection of settings. Check it again. Hope it could help.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 2, 2013 6:46 AM
  • User-166373564 posted

    Hi yorky

    I would just ignore this but it stops intelli-sense from working.

    First check the 'Show completion list after a character is typed' in TOOLS -> Options -> Text Editor -> C# -> IntelliSense.

    You can also consider resetting the user settings,

    Reset Visual Studio user settings

    If you need to restore default settings for your Visual Studio IDE, you can do the following

    Open Visual Studio Command Prompt and enter the following command.

    >devenv /ResetSettings

    If you need to load the settings from a specific .vssettings file, you can use the below command

    >devenv /ResetSettings SettingsFileName.vssettings

     Regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 3, 2013 5:09 AM

All replies

  • User-718146471 posted

    Take a look here: http://social.msdn.microsoft.com/Forums/vstudio/en-US/086495fd-2383-44b6-b4cb-89dfb3576f9e/visual-studio-2013-intellisense-issues?forum=visualstudiogeneral

     

    Hi Paul,
    
    Thank you for posting in the MSDN forum.
    
    Just to make this issue clearly, what kind of app are you developing? Whether all projects have the same issue? 
    Would you mind sharing me a simple sample? So I could repro this issue in my side with VS2013 RC. If it is related to the language developing like VC# app, you could check the setting under
    TOOLS->Options->Text Editor->the specific language(C#) ->IntelliSense. I have met a similar issue, the IntelliSense doesn’t work, but it works well after I reset my VS settings. TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”
    ->Choose a Default Collection of settings. Check it again. Hope it could help.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 2, 2013 6:46 AM
  • User882043084 posted

    hi, 

    I haven't changed any settings since upgrading.  Sure I can go ahead and reset them all but this is odd, it's quite random and reports all is ok and 

    then green underlines at different points during the day. 

    Monday, December 2, 2013 9:04 AM
  • User-166373564 posted

    Hi yorky

    I would just ignore this but it stops intelli-sense from working.

    First check the 'Show completion list after a character is typed' in TOOLS -> Options -> Text Editor -> C# -> IntelliSense.

    You can also consider resetting the user settings,

    Reset Visual Studio user settings

    If you need to restore default settings for your Visual Studio IDE, you can do the following

    Open Visual Studio Command Prompt and enter the following command.

    >devenv /ResetSettings

    If you need to load the settings from a specific .vssettings file, you can use the below command

    >devenv /ResetSettings SettingsFileName.vssettings

     Regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 3, 2013 5:09 AM
  • User882043084 posted

    Hi, 

    I checked the options as you suggested and completion is indeed ticket.  Might just have to go with reding the settings although 

    it seems a bit of a hammer to crack a nut. 

    Thanks 

    Tuesday, December 3, 2013 8:15 AM