locked
Windows 7 - SQL Server 2008 -- SSIS Script Environment Error - COMException - Help! RRS feed

  • Question

  • I am stumped. We have a clean Windows 7 Ultimate 64-bit Environment with a SQL Server 2008 SP1 install (Developer Edition.) The box is completely patched. When we create a new SSIS Integration Project with BIDS, add a Script Component or Task, lauch the Edit Script Button, we get this:

    Unable to load context message box followed by:

    TITLE: Microsoft Visual Studio

    ------------------------------

    Cannot show Visual Studio 2008 Tools for Applications editor.

    ------------------------------

    ADDITIONAL INFORMATION:

    The VSTA designer failed to load:  "System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.

       at VSTADTEProvider.Interop.VSTADTEProviderClass.GetDTE(String bstrHostID, UInt32 dwTimeout)

       at Microsoft.SqlServer.VSTAHosting.VSTAScriptingEngine.EnsureDTEObject()" (Microsoft.SqlServer.VSTAScriptingLib)

    ------------------------------

    BUTTONS:

    OK

    ------------------------------

    Binging around, we see that it has to do with the VSTA script environment not being found or corrupt. These systems are part of a domain in case that matters (it did work one time with the local admin account before the domain login corrupted the environment.) All of the solutions I have found online we have tried. I checked the registry for the location of scripts, I have copied the templates to the VS 2005 Templates folder, I have run the environment as the admin, etc. Nothing works. We even did a complete reinstall thinking that Office 2007 or VS.2008 Pro had something to do with it. I have a clean Win 7 install with SQL Server 2008 only trying to isolate the problem.

    We are at a complete loss and are tired. Any suggestions how to get this to work? It is frustrating!!

    Thanks!
    Michael

    Monday, October 26, 2009 9:10 PM

Answers

All replies

  • Windows 7 is just launched in India last week.
    Have not got to use it as yet.
    Not sure how many have.
    Hope this helps !!
    Sudeep   |    My Blog
    Tuesday, October 27, 2009 12:03 AM
  • Did I screw up and post this on the Indian MSDN site?
    Tuesday, October 27, 2009 12:13 AM
  • No you have posted it in the right place.
    Just that i'm from India. Wait to see if people have worked on Windows 7 and have come across similar issues.

    Hope this helps !!
    Sudeep   |    My Blog
    Tuesday, October 27, 2009 12:37 AM
  • Aur Kya Chal Reha hai?

    I did have the developer install the XP Virtual Environment which works for now. What a pain! I think this is a permissions problem on the templates.
    Tuesday, October 27, 2009 8:10 PM
  • I can say that I have this working with your scenario, and have been using it for a few months.  The issue shouldn't be limited to Win 7 though, as it is pretty much just Vista, so see if that helps in your "Binging" around...

    Have you seen this post?  http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/e5337b0c-7f70-4603-859e-fbc7d0cf1c37
    Phil Brammer | http://www.ssistalk.com | Twitter: http://twitter.com/PhilBrammer
    Tuesday, October 27, 2009 8:19 PM