none
"error : All pipe instances are busy." when deploying UMDF driver from VS2012 to Win8 RRS feed

  • Question

  • Hi,

    I'm walking through Write a UMDF driver based on a template using VS2012, Win7 SP1 x64 on my development PC. I successfully provisioned a Win8 x86 Release Preview target PC following the instructions in Configuring a Computer for Driver Deployment, Testing, and Debugging. On the last step of the "Write a UMDF driver" tutorial I hit F5 then eventually get this error in Visual Studio's output window:

    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Platforms\Win32\ImportAfter\DriverDeployment8.0.targets(69,9): error : All pipe instances are busy.
    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V110\Platforms\Win32\ImportAfter\DriverDeployment8.0.targets(69,9): error : 

    On the target PC I can see that it appears to have stalled on the "devcon -f install" command, which eventually completes after a few minutes. It seems to fail, as I see a flash of red text as it disappears.

    I then ran the devcon command line from an Administrator cmd prompt on the target PC, and got similar behaviour: Device node created, Updating drivers, then a long wait, then "devcon failed".

    Any solutions or suggested debugging steps would be much appreciated.

    Thanks,

    Doug

    Tuesday, October 23, 2012 5:05 PM

All replies

  • if the umdf host is set to break on load or start, it will wait for a debugger to attach. this can manifest as a devcon failure since we eventually time out and the pnp operation fails.

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, October 23, 2012 7:38 PM
  • Hi Doron,

    Thanks for the suggestion. I checked the registry on the target PC, both HostProcessDbgBreakOnDriverLoad and HostProcessDbgBreakOnDriverLoad are set to 0. Anything else I should look for?

    Regards,

    Doug

    Wednesday, October 24, 2012 12:00 PM
  • OK, I then found HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WUDF\DebugMode which had DebugModeFlags set to 7, I changed that to 0 and devcon install completes successfully immediately. Thanks very much for pointing me in the direction of a debugger timeout.

    This leads to the next question. According to How to Enable Debugging of a UMDF Driver, "When you use the F5 option in Visual Studio, all three flags are set for the deployed driver.", but this appears to break the devcon install step for me. How can I get VS debugging to work?

    Thanks,

    Doug

    Wednesday, October 24, 2012 12:09 PM
  • are you doing this on the remote macine or local dev box where you are compiling?


    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 24, 2012 3:04 PM
  • I set DebugModeFlags=0 on the remote machine. Everything else I have done as per http://msdn.microsoft.com/en-us/library/windows/hardware/hh439659(v=vs.85).aspx
    Wednesday, October 24, 2012 3:06 PM
  • try installing the umdf driver on your dev self host box. that way the debugger is not running remotely over the kernel debugger link

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, October 24, 2012 5:52 PM