Wrong local settings directory RRS feed

  • Question

  • Hello,

    I'm having some problems with TFS eclipse plugin on eclipse 3.7 (Indigo). TFS eclipse plugin keeps pointing local settings directory to "C:\Users\<user>\Local Settings\Application Data\Microsoft\Team Explorer\10.0" in which the access is denied.

    I think that the directory should be "C:\Users\<user>\AppData\Local" but i can't change it because I don't know where I can perform this.

    Can someone help me on this matter?

    The OS is Windows 7 64 bits

    Thank you.

    Thursday, January 19, 2012 11:42 AM


  • Hello,

    It was not a problem with the plugin. About two years ago I changed the user manually and also manually updated the registry but I did not remember the junction points!!

    That was the problem...junction points were pointing to the old user! I had to recreate them...after that everything worked...


    Thursday, January 19, 2012 10:19 PM

All replies

  • On Windows 7 there should be a link between the "Application Data" folder and AppData.  For example if you browse to C:\Users\<user>\Local Settings\Application Data\Microsoft then it should give you the same folder as if you were in C:\Users\<user>\AppData\Local\Microsoft

    I seem to remember the reason why we go to the older path name on Windows is to maintain compatibility with Windows XP in the Eclipse plug-in.  (Windows Vista and Windows 7 kept the links from the old XP location when Windows Vista was introduced to support back compatibility).  We should look into this again to see if we should be doing this a better way now.

    However, I'm not sure if this is the root cause of the problem you are seeing.  What problems are you seeing?  Is your user profile directory stored locally or is it re-directed to be on a network share?

    Many thanks,


    Thursday, January 19, 2012 12:39 PM
  • "Is your user profile directory stored locally or is it re-directed to be on a network share?"


    Exported configuration:

    ALLUSERSPROFILE            C:\ProgramData                                                                     
    APPDATA                    C:\Users\<user>\AppData\Roaming                                                    
    CommonProgramFiles         C:\Program Files\Common Files                                                      
    CommonProgramFiles(x86)    C:\Program Files (x86)\Common Files                                                
    CommonProgramW6432         C:\Program Files\Common Files                                                      
    COMPUTERNAME               <name>
    ComSpec                    C:\Windows\system32\cmd.exe                                                        
    FP_NO_HOST_CHECK           NO                                                                                 
    HOMEDRIVE                  C:                                                                                 
    HOMEPATH                   \Users\<user>
    JAVA_HOME                  C:\Program Files\Java\jdk1.6.0_22                                                  
    LOCALAPPDATA               C:\Users\<user>\AppData\Local                                                      
    LOGONSERVER                \\<name>                                                                       
    NUMBER_OF_PROCESSORS       4                                                                                  
    OS                         Windows_NT                                                                         
    Path                       C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\OraClient10g\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Windows Live\Shared; 
    PATHEXT                    .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC                              
    PROCESSOR_ARCHITECTURE     AMD64                                                                              
    PROCESSOR_IDENTIFIER       Intel64 Family 6 Model 15 Stepping 11, GenuineIntel                                
    PROCESSOR_LEVEL            6                                                                                  
    PROCESSOR_REVISION         0f0b                                                                               
    ProgramData                C:\ProgramData                                                                     
    ProgramFiles               C:\Program Files                                                                   
    ProgramFiles(x86)          C:\Program Files (x86)                                                             
    ProgramW6432               C:\Program Files                                                                   
    PSModulePath               C:\Windows\system32\WindowsPowerShell\v1.0\Modules\                                
    PUBLIC                     C:\Users\Public                                                                    
    SESSIONNAME                Console                                                                            
    SystemDrive                C:                                                                                 
    SystemRoot                 C:\Windows                                                                         
    TEMP                       C:\Users\<user>\AppData\Local\Temp                                                 
    TMP                        C:\Users\<user>\AppData\Local\Temp                                                 
    USERDOMAIN                 <name>
    USERNAME                   <user>
    USERPROFILE                C:\Users\<user>

    windir                     C:\Windows                     

    On directories tab of the support Window under Team Explorer settings directory i can see the pointed directory:  "C:\Users\<user>\Local Settings\Application Data\Microsoft\Team Explorer\10.0" with a warning below: "Directory does not exist".

    The error:

    !ENTRY org.eclipse.core.jobs 4 2 2012-01-19 12:35:46.732
    !MESSAGE An internal error occurred during: "Refreshing TFS Server information for http://abc:8080/tfs/DefaultCollection/".
    !STACK 0
    java.lang.RuntimeException: Error creating directories up to C:\Users\<user>\Local Settings\Application Data\Microsoft\Team Explorer\10.0\db\4.0a-ebbdc96d-c3e0-451e-8a4b-472f7e606874\data.  Possible permissions problem.
     at com.microsoft.tfs.core.persistence.FilesystemPersistenceStore.initialize(FilesystemPersistenceStore.java:92)
     at com.microsoft.tfs.core.internal.db.ConnectionConfiguration.tryLock(ConnectionConfiguration.java:264)
     at com.microsoft.tfs.core.internal.db.ConnectionConfiguration.getDirectoryForDiskDatabase(ConnectionConfiguration.java:249)
     at com.microsoft.tfs.core.internal.db.ConnectionConfiguration.<init>(ConnectionConfiguration.java:96)
     at com.microsoft.tfs.core.internal.db.ConnectionConfiguration.<init>(ConnectionConfiguration.java:69)
     at com.microsoft.tfs.core.clients.workitem.internal.WITContext.<init>(WITContext.java:91)
     at com.microsoft.tfs.core.clients.workitem.WorkItemClient.getContext(WorkItemClient.java:382)
     at com.microsoft.tfs.core.clients.workitem.WorkItemClient.refreshCache(WorkItemClient.java:304)
     at com.microsoft.tfs.client.common.server.TFSServer.refresh(TFSServer.java:151)
     at com.microsoft.tfs.client.common.server.TFSServer.access$000(TFSServer.java:23)
     at com.microsoft.tfs.client.common.server.TFSServer$1.run(TFSServer.java:106)
     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    • Edited by lpmbv Thursday, January 19, 2012 12:57 PM
    Thursday, January 19, 2012 12:53 PM
  • Solved.

    Thank you.

    Thursday, January 19, 2012 5:25 PM
  • what was the solution in the end?
    Thursday, January 19, 2012 5:38 PM
  • Hello,

    It was not a problem with the plugin. About two years ago I changed the user manually and also manually updated the registry but I did not remember the junction points!!

    That was the problem...junction points were pointing to the old user! I had to recreate them...after that everything worked...


    Thursday, January 19, 2012 10:19 PM
  • Ah, that would do it!

    Thanks for coming back to us.  

    Just to let you know that we are going to change things in TEE 11 so that we look this up a different way rather than relying on these old back-compat junction points.

    Friday, January 20, 2012 10:42 AM