locked
How can i do a popup with image? RRS feed

  • Question

  • User324531 posted

    I want to display a complet image when the user touch the icon, per example. This is same function of whatsapp, that when I touch the contact's image, the image is expand, like a popup. Anyone can help me?

    Thursday, May 18, 2017 1:21 AM

Answers

  • User2148 posted

    https://github.com/rotorgames/Rg.Plugins.Popup

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, May 18, 2017 5:25 AM
  • User324531 posted

    thanks, i'll test

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, May 18, 2017 10:30 AM

All replies

  • User2148 posted

    https://github.com/rotorgames/Rg.Plugins.Popup

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, May 18, 2017 5:25 AM
  • User324531 posted

    thanks, i'll test

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, May 18, 2017 10:30 AM
  • User351573 posted

    Hi @AlessandroCaliaro , @AlexAlvesSilva and @RianDutra Install Rg.Plugins.Popup on all the platforms. When I try initialization in android, getting error :) Thanks

    Thursday, January 18, 2018 11:48 AM
  • User240159 posted

    Clean project, Restore Nugets, restart VS, rebuild.

    Thursday, January 18, 2018 12:04 PM
  • User351573 posted

    @NamyslawSzymaniuk said: Clean project, Restore Nugets, restart VS, rebuild.

    Done, but again the same issue :)

    Thursday, January 18, 2018 12:10 PM
  • User240159 posted

    Check, whether Rg.Plugins.Popup is really installed, also at Android project.

    Also check, whether also simple import is not working:

    using Rg.Plugins.Popup;

    Thursday, January 18, 2018 12:12 PM
  • User351573 posted

    @NamyslawSzymaniuk said: Check, whether Rg.Plugins.Popup is really installed, also at Android project.

    Also check, whether also simple import is not working:

    using Rg.Plugins.Popup;

    Rg.plugins package is installed on all the projects. Here is the screenshot of android project. Simple import is also not working :'(

    Thursday, January 18, 2018 12:26 PM
  • User351573 posted

    Created a new project and install the plugin again on all platform, but the result is same.

    Thursday, January 18, 2018 12:38 PM
  • User324531 posted

    This's occured with me, but I couldn't solve it. I deleted my project and created a new and this problem dissaper. Maybe it's a version of your VS or of your Xamarin, try to updates it, and try to install the plugin in projects one to one and verify if the error continue

    Thursday, January 18, 2018 9:47 PM
  • User364336 posted

    From the screenshot, you've installed version 1.0.4. Try upgrading it to the latest: 1.1.1.5.7 It works quite well on my end.

    Friday, January 19, 2018 2:37 AM
  • User155041 posted

    @Sreeee said:

    @NamyslawSzymaniuk said: Check, whether Rg.Plugins.Popup is really installed, also at Android project.

    Also check, whether also simple import is not working:

    using Rg.Plugins.Popup;

    Rg.plugins package is installed on all the projects. Here is the screenshot of android project. Simple import is also not working :'(

    can you expand references and check wether Rg plugins is there or not ???

    Friday, January 19, 2018 5:00 AM
  • User351573 posted

    Yes, Rg plugins is present inside of the reference

    Friday, January 19, 2018 5:08 AM
  • User351573 posted

    @Charwaka said:

    @Sreeee said:

    @NamyslawSzymaniuk said: Check, whether Rg.Plugins.Popup is really installed, also at Android project.

    Also check, whether also simple import is not working:

    using Rg.Plugins.Popup;

    Rg.plugins package is installed on all the projects. Here is the screenshot of android project. Simple import is also not working :'(

    can you expand references and check wether Rg plugins is there or not ???

    Plugins are there :)

    Friday, January 19, 2018 9:17 AM
  • User351573 posted

    @mikemac said: From the screenshot, you've installed version 1.0.4. Try upgrading it to the latest: 1.1.1.5.7 It works quite well on my end.

    For mine latest version is 1.0.4, didn't show 1.1.15.7.

    Sunday, January 21, 2018 2:22 PM
  • User351573 posted

    @AlexAlvesSilva said: This's occured with me, but I couldn't solve it. I deleted my project and created a new and this problem dissaper. Maybe it's a version of your VS or of your Xamarin, try to updates it, and try to install the plugin in projects one to one and verify if the error continue

    I also delete the current project and create new, but the problem still appearing. For mine latest version for popup is 1.0.4. I am using vs 2017.

    Sunday, January 21, 2018 2:27 PM
  • User240159 posted

    Check Include prerelease just next to "search" of plugins, to see pre-releases.

    Monday, January 22, 2018 7:17 AM
  • User155041 posted

    @Sreeee said:

    @mikemac said: From the screenshot, you've installed version 1.0.4. Try upgrading it to the latest: 1.1.1.5.7 It works quite well on my end.

    For mine latest version is 1.0.4, didn't show 1.1.15.7.

    Have u tried creating new project ?

    Monday, January 22, 2018 7:32 AM
  • User240159 posted

    Or upload here whole package solution.

    Monday, January 22, 2018 8:43 AM
  • User351573 posted

    @Charwaka said:

    @Sreeee said:

    @mikemac said: From the screenshot, you've installed version 1.0.4. Try upgrading it to the latest: 1.1.1.5.7 It works quite well on my end.

    For mine latest version is 1.0.4, didn't show 1.1.15.7.

    Have u tried creating new project ?

    Yes, create a new solution and install packages for the whole solution, still the same issue.

    Monday, January 22, 2018 9:04 AM
  • User171749 posted

    This is the nuget page for the 1.1.3.74-pre version. Install it through the package manager if you don't know how to turn on pre-release packages.

    https://www.nuget.org/packages/Rg.Plugins.Popup/1.1.3.73-pre

    Monday, January 22, 2018 9:06 AM
  • User351573 posted

    @NamyslawSzymaniuk said: Check Include prerelease just next to "search" of plugins, to see pre-releases.

    Hi @Charwaka When check include prerelease showing 1.1.3.73. And now the error is gone :) Thank you

    Monday, January 22, 2018 9:14 AM
  • User351573 posted

    @Charwaka and @NamyslawSzymaniuk I install the plugin for the entire solution which was successfully completed. But when run showing The referenced component 'Rg.Plugins.Popup.IOS' could not be found in ImagePopUp.iOS

    Monday, January 22, 2018 9:47 AM
  • User240159 posted

    If it's warning, and popups are working in the iOS UI, then forget about this. Or you can restore nugets, clean, and rebuild again and again, together with restarting VS.

    I also commonly have some strange errors with nugets/dll's on updating/installing new components.

    Monday, January 22, 2018 9:50 AM
  • User351573 posted

    @NamyslawSzymaniuk said: If it's warning, and popups are working in the iOS UI, then forget about this. Or you can restore nugets, clean, and rebuild again and again, together with restarting VS.

    I also commonly have some strange errors with nugets/dll's on updating/installing new components.

    It is a warning, because of this warning the project not running, build always fail. Try uninstalling and reinstalling the package, but not get any luck.

    Monday, January 22, 2018 11:17 AM
  • User367329 posted

    From new versions, you don't need specific initialization on Android or iOS. Just install package and work on it.

    Saturday, April 14, 2018 7:09 PM