none
Invalid object name 'sys.configurations'. (.Net SqlClient Data Provider) RRS feed

  • Question

  • Just trying to get started with a connection....

    I was able to create a database using the Web-based Server Administration page.  When I try to Add a Connection in VS 2008, the "Test Connection" succeeds, but I get the error:

    Invalid object name 'sys.configurations'. (Microsoft SQL Server, Error: 208)

    The same error occurs when trying to connect in SQL Server 2008 Management Studio.

    At one point, I got this error:

    Unable to add data connection in Server Explorer:

    The current user account was invoked with SETUSER or SP_SETAPPROLE. Changing databases is not allowed.

    Thanks for any advice,

    Ken

     


    Author: ASP.NET 3.5 For Dummies
    Saturday, August 22, 2009 10:42 PM

Answers

  • Hi Ken,

    Adding a connection to SQL Azure in VS isn't currently working.  We are looking into it, but for now you can use SSMS.  Follow these steps to get started:

    1. cancel out of the first connection dialog that pops up.
    2. click on the New Query button from the toolbar (upper left)
    3. entered
           Server name: full servername
           Login: just the username (no @...)
    4. Under Options, Connect to Database, I typed TestDb1
    5. Hit connect.

    Stan
    Program Manager, SQL Azure
    Saturday, August 22, 2009 10:52 PM
  • I see items in the Object Explorer on Azure. What made all the difference for me was installing Microsoft® SQL Server® 2008 R2 November Community Technology Preview - Express Edition. Mine is version 10.50.1352.12. 

    http://www.microsoft.com/downloads/details.aspx?FamilyID=c772467d-e45b-43e1-9208-2c7b663d7ad1&displaylang=en

    Ken

    Author: ASP.NET 3.5 For Dummies
    • Marked as answer by Cox, Ken Wednesday, April 7, 2010 6:27 AM
    Wednesday, January 13, 2010 8:20 PM
  • I Agree with Ken Cox. It perfectly works on SQL Server 2008 R2 version.

     

    • Marked as answer by Cox, Ken Wednesday, April 7, 2010 6:27 AM
    Wednesday, April 7, 2010 6:26 AM

All replies

  • Hi Ken,

    Adding a connection to SQL Azure in VS isn't currently working.  We are looking into it, but for now you can use SSMS.  Follow these steps to get started:

    1. cancel out of the first connection dialog that pops up.
    2. click on the New Query button from the toolbar (upper left)
    3. entered
           Server name: full servername
           Login: just the username (no @...)
    4. Under Options, Connect to Database, I typed TestDb1
    5. Hit connect.

    Stan
    Program Manager, SQL Azure
    Saturday, August 22, 2009 10:52 PM
  • Hi,

    i understand that you've mentioned adding connection to SQLAzure in VS is not working (dated 22th Aug.)
    Is it working now? If no, do you know when will it be ready?

    Thanks.
    Monday, September 14, 2009 6:17 AM
  • I am having the same issue.

    After following your advice on connecting to the database it looks like I am connected. If I mouse over the CloudNode.dbo.MasterDB… is see my databases but if I select one of them I get an error “The database (master, ASD, etc.) in not accessible". Then the connection is closed?

    Is there some configuration I am missing.

    Thanks,
    Lewis

    Friday, September 18, 2009 12:44 AM
  • I am getting the same behavior.  I am in SSMS 2008.
    Friday, September 18, 2009 4:10 AM
  • Hi

    At this point I am only working in SSMS and am having the same trouble as the first post - Invalid object name 'sys.configurations'. (Microsoft SQL Server, Error: 208)

    The connection Azure SQL Server [um, ____? No, that isnt going to work] is made OK and the test connection works.   When I try to open the DB, no luck.  Any ideas?

    Thank you
    Mike
    Monday, September 21, 2009 12:57 PM
  • Hi All,

    I had the same problem: Invalid object name 'sys.configurations'. (Microsoft SQL Server, Error: 208) today. I did the steps mentioned in the document Prepare your SQL Azure Account which comes the Azure Toolkit.

    1. Connect using "New Query" (instead of using Connect Object Explorer) from SQL Server 2008. Give SQL Azure Account Name (say AZ1) and password to login. Here you will have access to only the master database.
    2. Create a new database (say DB1).
    3. Create a new login (say LG1).
    4. Now close the Query window. Click "New Query", click Options, select the default database as DB1. Connect to it using SQL Azure Account Name AZ1.
    5. Create a new user (say TUSER1) using the login LG1.
    6. Give 'db_owner' privilege to TUSER1.
    7. Close the Query window. Click "New Query", click Options, choose DB1 as the default database, login as TUSER1.

    Now, you have created a database named DB1, with TUSER1 as the login user with required privileges. Now you can create tables and procedures in DB1. We could have just used the SQL Azure Account Name AZ1 for DB1 also, but for security reasons, it is good to create a separate user (TUSER1) to access DB1.

    Hope this is helpful.

    • Proposed as answer by Adam Wengert Wednesday, November 3, 2010 11:16 PM
    Monday, November 9, 2009 2:03 AM
  • I am having the same problem.  Currently evaluating Cloud computing, looking at AWS AMI stuff as well as Azure.   The AWS stuff works perfectly (once one has figured out the credentials, keys, tokens etc.).

    Would like to work with Azure solution...  BUT frustrated as MS should really do better than this - wasting time by having to figure out what should be simple - reduces all confidence that this thing will be ready for production in Q1 2010...  AND something is up with the SQL Azure site this evening.. lots of page crashes etc.

      -- peter

    Monday, November 23, 2009 3:17 AM
  • When you create a new query and the connection dialog box pops up, click on the Options >> button, and on the Connection Properties tab type in the database name in the Connect to database: area. then validate Login tab entries and click on Connect. That'll fix it.

    ilya
    Monday, November 30, 2009 9:40 PM
  • thats works fine for new query window but if I try to browse the object explorer the connection dialog box pops up again and again I get the error:

    Invalid object name 'sys.configurations'

    My SSMS version is:

    Microsoft SQL Server Management Studio Complete      10.0.2531.0

    is that ok?
    paburgos
    Tuesday, January 5, 2010 1:29 AM
  • Yeah.. i'm connected but i don't see anything in object explorer....
    mitnerd
    Wednesday, January 13, 2010 8:09 PM
  • Object Explorer wasn't supported by SQL Azure, last i checked. Sounds like your experience confirms that it's still the case.
    Wednesday, January 13, 2010 8:13 PM
  • I see items in the Object Explorer on Azure. What made all the difference for me was installing Microsoft® SQL Server® 2008 R2 November Community Technology Preview - Express Edition. Mine is version 10.50.1352.12. 

    http://www.microsoft.com/downloads/details.aspx?FamilyID=c772467d-e45b-43e1-9208-2c7b663d7ad1&displaylang=en

    Ken

    Author: ASP.NET 3.5 For Dummies
    • Marked as answer by Cox, Ken Wednesday, April 7, 2010 6:27 AM
    Wednesday, January 13, 2010 8:20 PM
  • I Agree with Ken Cox. It perfectly works on SQL Server 2008 R2 version.

     

    • Marked as answer by Cox, Ken Wednesday, April 7, 2010 6:27 AM
    Wednesday, April 7, 2010 6:26 AM
  • Hi Stan Kitsis,

    yes, I can make a connection using SSMS following your instruction. Although I am connected to the server, I don't see anything on object explore. When trying to make connection to the object explore, I get the same error again: Invalid object name 'sys.configurations'. (Microsoft SQL Server, Error: 208)

    Is this a bug or am I doing something wrong?

    Thanks.

    Tuesday, May 18, 2010 7:12 PM
  • That's because you're using a version of SSMS that's earlier than SSMS 2008 R2 (see previous discussion of this thread). You need the R2 version to get SQL Azure support in Object Explorer. You can download a free SSMS 2008 R2 RTM Express Edition from http://www.microsoft.com/express/Database/InstallOptions.aspx (see "Management Tools option) or get it as part of SQL Server 2008 R2 RTM. AFAIK, including the latest cumulative update for SQL Server 2008 SP1 that came out yesterday, SQL Azure support has not been "backported" to SSMS 2008 pre-R2.

    Hope this helps, Bob Beauchemin, SQLskills

    Tuesday, May 18, 2010 8:11 PM
  • Bless you!  The problem is apparently SSMS trying to connect to master to get everything in the object explorer, clicking on "New Query" worked for me.
    Sunday, September 2, 2012 4:17 AM