locked
Publish Application in azure unable to create token when sign in RRS feed

  • Question

  • User55322542 posted
    I run the O365-ASPNETMVC-Start(https://github.com/OfficeDev/O365-ASPNETMVC-Start) in local host (https://localhost:44300/) its working fine everything. When i publish code in azure website we are facing problems.

    1) Open the URL and after sign in click any link like Email it showing error message.
    but it working fine in localhost. What we observed in localhost When sign in enter credentials click signin button one ADALTokenCache row inserted into database (ADALTokenCacheDb) but not inserted any row when published url signin. After i tried different way through localhost i pointed to ServerDB and tried to signin now ADALTokenCache row inserted in serverdb working fine click Emil anything. after tried published URL with same MailID its working fine. So each emailID first time only problem, once record inserted after working fine. What is the problem.

    2) Signout issue--> Localhost its redirect to home page and display sign in button but in published code redirect to home page with username and signout buttons. what is the problem.

    Can you please help me any permissions are required, i tried different ways but .no use.

    Thanks,
    Hemanth.
    Thursday, June 30, 2016 8:08 AM

All replies

  • User1724605321 posted

    Hi hemanth1707113,

    After you publish to Azure , you should make sure  you have changed the actual ReplyURL to point to the hosted/deployed site url  of your app, and of course, deliver appropriate "Delegated" permissions for your application in Azure AD  .

    Best Regards,

    Nan Yu

    Friday, July 1, 2016 5:49 AM
  • User55322542 posted
    Hi Nan yu,

    Thanks for reply. ya i have done that changes. I entered hosted url in reply URL and same azureAD for both localhost and hosted url, so as per my knowledge not required any more permissions. Is there any permissions required could you please help me.

    Thanks,
    Hemanth.
    Friday, July 1, 2016 10:28 AM