locked
Security validation for this page is invalid error - navigation not working RRS feed

  • Question

  • Hi all,

    We have a farm wide issue with the security validation; when turned on via CA it is not possibje to edit the Site Navigation of any site collection in the farm.

    When turned off (which for security reasons is not an option) it works and we can edit the Site Navigation of Sites in the farm just fine.

    What's remarkable is that when we have the Security validation turned off in the CA, some customized functionality (buttons on all sites) are not responding (on buttonclick there is no response).

    I've searched the Inet and found most similar issues, but they mostly point out to custom code solutions such as "FormDigest" or manually turning the Security validation off on per site collection or site basis. We don't want custom solutions, since we think turning the security validation on, shouldn't break any OOB functionality such as the Navigation editing, which is the case now.

    Any thoughts how we can solve this?

    I'm no developer fyi, I just happen to have development as an interest


    I am a SharePoint Infrastructure Engineer, focussed on Administration and Installation of SharePoint Server environments.
    • Moved by Mike Walsh FIN Thursday, August 25, 2011 9:15 AM admin q not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, August 25, 2011 9:04 AM

Answers

  • The above is exactly a reproduction of our issue. So far it looks like the June CU has something to do with it (possible cause), since we reproduced this error.

    To understand this issue, i think you have to understand the security validation

    We applied the FormDigest control in the simple.master (see link for additional info) and so far it seems to work in our test-environment in which we also applied the June CU and reproduced the error.

    However, customizing the simple.master seems a very 'ugly' solution. We are considering the above as a temporarily workaround and will contact Microsoft to verify this is a known problem, thus to find a permanent fix.


    I am a SharePoint Infrastructure Engineer, focussed on Administration and Installation of SharePoint Server environments.
    • Marked as answer by OptimistBrown Friday, August 26, 2011 9:19 AM
    Friday, August 26, 2011 7:14 AM

All replies

  • Good day to you all!

    I can also replicate this issue on my 2007 SharePoint farm.  The steps are as follows:

    1. Open any SharePoint site.
    2. Click on Site Actions, then Site Settings.
    3. Click on Navigation.
    4. Click to highlight an item in the global navigation list.
    5. Click Edit...
    6. Change the title of the item and then click OK.  The error will occur.

    This issue is global, as I tried the same thing in a different web application and I recieved the same results.


    Jesse Schuchart, MCSE
    Thursday, August 25, 2011 2:49 PM
  • The above is exactly a reproduction of our issue. So far it looks like the June CU has something to do with it (possible cause), since we reproduced this error.

    To understand this issue, i think you have to understand the security validation

    We applied the FormDigest control in the simple.master (see link for additional info) and so far it seems to work in our test-environment in which we also applied the June CU and reproduced the error.

    However, customizing the simple.master seems a very 'ugly' solution. We are considering the above as a temporarily workaround and will contact Microsoft to verify this is a known problem, thus to find a permanent fix.


    I am a SharePoint Infrastructure Engineer, focussed on Administration and Installation of SharePoint Server environments.
    • Marked as answer by OptimistBrown Friday, August 26, 2011 9:19 AM
    Friday, August 26, 2011 7:14 AM