none
Hiding meeting response buttons in the reading pane RRS feed

  • Question

  • I have developed custom ribbon buttons to respond to the meeting requests. I made disabled the default Group Respond menu. But the buttons are being displayed in the reading pane. How can I hide those buttons? I tried to get the active explorer and use the ShowPane method. But this method can be accessed like FolderList, Preview, NavigationPane.

    Monday, April 1, 2019 6:09 AM

All replies

  • You cannot hide these buttons. You can of course modify the message class of the meeting requests so that Outlook does not even think it is a meeting request and renders it as a plain message .

    Dmitry Streblechenko (MVP)
    http://www.dimastr.com/redemption
    Redemption - what the Outlook
    Object Model should have been
    Version 5.5 is now available!

    Monday, April 1, 2019 4:54 PM
  • Thank you Dimitry for the information. Do you have any other idea? What is the best solution to provide the custom meeting respond button for attendees? 

    As I said, I developed custom ribbon button to respond it. Then i added a custom property into the meeting request while i am sending it. So that, when the attendee opened the request, if it is a custom meeting request, the default respond buttons in the ribbon are being disabled.Otherwise, my custom buttons are being disabled.

    Wednesday, April 3, 2019 8:49 AM
  • Can you just react to the events caused by the default buttons? What would your buttons do differently?

    Dmitry Streblechenko (MVP)
    http://www.dimastr.com/redemption
    Redemption - what the Outlook
    Object Model should have been
    Version 5.5 is now available!

    Friday, April 5, 2019 4:25 AM
  • Default buttons execute custom field and default meeting information to the SharePoint list. How can I handle those default buttons event?

    I can handle the item received. When I checked the received item whether it is a meeting request response or not, if it is a meeting request response, I checked that user response request. But it still appeared none.

    Sunday, April 7, 2019 9:43 PM