none
its about installing the .net framework v4.0.30319 RRS feed

  • Question

  • good day!  

    i just installed an on line game but when i was tried to launch it an error said "to run this application, you must first install one of the following versions of the .net framework: v4.0.30319.  contact your application publisher for instructions about obtaining the appropriate version of the .net framework."  then when i googled i found the same problem here in ur site then i followed the instructions on how to resolve it... but then when i tried to install the . net framework it said " Set up has detected that this computer does not meet the requirements to complete this operation.  the following issues must be resolved before you ccan procees.

    BLOCKING issues:

    you must install the 32 bit windows imaging component (WIC) before you run set up."  then i tried to follow the instruction on the link it provided and downloaded the WIC but nothing happened.

     

    please help.. dunnno what to do im really not good at this things.. thanks

    Tuesday, August 30, 2011 11:49 PM

Answers

  • Hi Rossmcdaniel,

     

    Welcome to the MSDN forum.

     

    First, could you please let me know your OS version and service pack level?

     

    Second, here are the requirements of .NET Framework 4:

    Supported Operating Systems:

    ·         Windows XP Service Pack 3

    ·         Windows Server 2003 Service Pack 2

    ·         Windows Vista Service Pack 1 or later

    ·         Windows Server 2008 (not supported on Server Core Role)

    ·         Windows 7

    ·         Windows Server 2008 R2 (not supported on Server Core Role)

    ·         Windows 7 Service Pack 1

    ·         Windows Server 2008 R2 Service Pack 1

    Supported Architectures:

    ·         X86

    ·         X64

    ·         Ia64 (some features are not supported on ia64 for example, WPF)

    Hardware Requirements:

    ·         Pentium 1GHz or higher with 512 MB RAM or more

    ·         Minimum disk space:

    o   X86 – 850 MB

    o   X64 – 2 GB

    Prerequisites:

    ·         Windows Installer 3.1 or later

    ·         Internet Explorer 5.01 or later

     

    Third, you can download WIC from: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=32

    Supported Operating Systems: Windows Server 2003, Windows Server 2003 R2 Datacenter Edition (32-Bit x86), Windows Server 2003 R2 Enterprise Edition (32-Bit x86), Windows Server 2003 R2 Standard Edition (32-bit x86), Windows XP Service Pack 2

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Alexander Sun Monday, September 5, 2011 2:38 AM
    Friday, September 2, 2011 2:31 AM

All replies

  • Friend,
       Can you please share the system configuration(including OS)?

    -- Thanks Ajith R Nair
    Wednesday, August 31, 2011 12:13 AM
  • Bet you're running Windows XP, correct?

    1. If you don't already have SP3 for XP installed, you must do that first.

    2. Read and follow the answer in this thread:

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/820395d3-e044-490a-8c3f-0e8357407b2b

     

    Wednesday, August 31, 2011 4:47 AM
  • Hi Rossmcdaniel,

     

    Welcome to the MSDN forum.

     

    First, could you please let me know your OS version and service pack level?

     

    Second, here are the requirements of .NET Framework 4:

    Supported Operating Systems:

    ·         Windows XP Service Pack 3

    ·         Windows Server 2003 Service Pack 2

    ·         Windows Vista Service Pack 1 or later

    ·         Windows Server 2008 (not supported on Server Core Role)

    ·         Windows 7

    ·         Windows Server 2008 R2 (not supported on Server Core Role)

    ·         Windows 7 Service Pack 1

    ·         Windows Server 2008 R2 Service Pack 1

    Supported Architectures:

    ·         X86

    ·         X64

    ·         Ia64 (some features are not supported on ia64 for example, WPF)

    Hardware Requirements:

    ·         Pentium 1GHz or higher with 512 MB RAM or more

    ·         Minimum disk space:

    o   X86 – 850 MB

    o   X64 – 2 GB

    Prerequisites:

    ·         Windows Installer 3.1 or later

    ·         Internet Explorer 5.01 or later

     

    Third, you can download WIC from: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=32

    Supported Operating Systems: Windows Server 2003, Windows Server 2003 R2 Datacenter Edition (32-Bit x86), Windows Server 2003 R2 Enterprise Edition (32-Bit x86), Windows Server 2003 R2 Standard Edition (32-bit x86), Windows XP Service Pack 2

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Alexander Sun Monday, September 5, 2011 2:38 AM
    Friday, September 2, 2011 2:31 AM