locked
Lookup Task fails in a package when executed as a child but not when executed as a parent RRS feed

  • Question

  • Hi,

     I have lose 2 days trying to understanf the following error:

     I have a master package with several child ones. When I execute the master one of the child packages suffers an error in a Data Flow Task when executing a Loojup component:

    [SSIS.Pipeline] Error: SSIS Error Code DTS_E_PROCESSINPUTFAILED.  The ProcessInput method on component "Retrieve Activity" (894) failed with error
    code 0x80070057 while processing input "Lookup Input" (895).  The identified component returned an error from the ProcessInput method. The error is specific to the component, but the error is fatal and will cause the Data Flow task to stop running.  There may be error messages posted before this with more information about the failure.

     The same child package where the error appears contains other lookup tasks that are executed properly.

     Surprisingly when the child package is executed alone the error does not appear and the package executes properly.

     I have lost 2 days comparing the tasks with other ones and checking properties and I haven't found the clue. I have found in the forum a similar post with a related problem but I don't know how to fix  my problem http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/3425381c-267e-4700-afbb-f1faf6a81fdd.

     

      If someones has any idea it will be welcomed.

      Thanks in advance,

     

     

     

    http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/3425381c-267e-4700-afbb-f1faf6a81fdd

     

    Wednesday, September 8, 2010 1:11 PM

Answers

All replies

  • Is the failing Lookup structurally identical to any other Lookup in the parent or other children?  By this, I mean the table it's referring to (or the SQL statement you've used), and the key columns and the retrieved columns?  I recall issues where SSIS attempts to re-use caches for identically configured lookups and has problems with doing that.

    As an other option to try solving the issue - have you tried running that package "out of process" in the Execute Package Task?  (Or is that just in the Execute Process Task?...)


    Todd McDermid's Blog Talk to me now on
    Wednesday, September 8, 2010 3:11 PM
  •  Hi Todd,

     

     First of all, thanks by your interest. I can confirm you that both lookups are structural identical. Both refer the same table and use the same key columns. I have check that fails remains even if I don-t use any kind of cache. I have also tried with the option "out of process" with any success.

     

     I am bit desperate...

     

    Friday, September 17, 2010 10:04 AM
    • Marked as answer by alf_gon Friday, September 17, 2010 12:31 PM
    Friday, September 17, 2010 10:15 AM
  • Thanks a lot Sorna,

     

    Its basically the same error and the purposed workaround (remove non-matech ouput) also works. I don't understand how the error has remained in 2008 version.

     

    Thanks again,

    Friday, September 17, 2010 12:31 PM
  • Hi Mate,

    You have managed to work this out? because I am experiencing the same problem and I don't have any clue why it is happening and what was changing from 2005.

    Any way for those of us how are wandering what we are talking about, we have an issue with redirecting error rows from lookup/convert/derived and so on…without any reasonable reason, it used to work just fine on SSIS 2005 but after the conversion to 2008 it stopped working.

     

    Tuesday, May 3, 2011 12:23 PM