EWS Managed API-Null pointer exception when binding to an appointment RRS feed

  • Question

  • Hi all, I am uisng Java EWS Managed API 1.1.3 with Exchange 2007 SP 1 and I am trying to delete a recurring meeting by binding to the master id as follows:

    Appointment meeting = Appointment.bind(service, new ItemId(masterIDstr));

    I get the following null pointer exception:


    I double checked that the masterIDstr is valid.  Any ideas?

    Friday, February 17, 2012 9:30 PM

All replies

  • I also tried with the EWS Java API 1.1.5 and I still get the null pointer exception.  The only change I made to that API's jar is in, where I commented out lines 249, 250, and 256.
    Sunday, February 19, 2012 5:49 AM
  • Seriously?!  Noone has encountered this problem?
    Wednesday, February 22, 2012 12:02 AM
  • Hi,

    I also had a similar issue.

    But this is solved in the release 1.1.3. Now everything works fine for me. 

    Are you getting this exception in a stand alone application or is it happening in a web application?

    From the code, it seems to me that Thread.currentThread().getContextClassLoader().getResource("microsoft/exchange/webservices/data/") is returning null. 

    You could actually verify that file is present in the EWSAPI-1.1.5.jar in the package "microsoft/exchange/webservices/data". 



    Monday, February 27, 2012 7:26 AM
  • Thank you so much for replying Paul.  I am getting this error in a standalone application.  I checked my jar and I have and but no 
    Tuesday, February 28, 2012 6:42 AM
  • Just an FYI - I found the is in the root folder of the extracted EWS toolkit.

    I added the properties file to the package and the NullPointerException went away

    • Edited by Cary Bran Saturday, June 9, 2012 1:33 AM
    Saturday, June 9, 2012 12:44 AM
  • Hi,

    I'm having the same problem. What exactly place you added the file

    Tuesday, September 10, 2013 7:49 PM