locked
App Deploy Error "Error : DEP0800" while trying to run a XAML, C++ app on VS2012 Ultimate RC

    Question

  • Hi,

    I'm facing a Deploy error when I tried to run a XAML, C++ sample app from MSDN on VS2012 Ultimate RC version. This is the error I'm seeing when I try to run the app,

    Error : DEP0800 : The required framework "C:\Program Files\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.VCLibs\11.0\.\AppX\Debug\ARM\Microsoft.VCLibs.ARM.Debug.11.appx" failed to install. 

    Windows cannot install package Microsoft.VCLibs.110.Debug because the package requires architecture ARM, but this computer has architecture x86.

    The environment that I'm using is VS2012 Ultimate RC version on Windows 8 Enterprise Evaluation.

    The same sample app runs on the environment with VS2012 Ultimate RC on Windows 8 Release Preview without any issues.

    Does this mean that I need to use different version of VS2012 for Windows 8 Enterprise Evaluation?

    Could someone please let me know what exact version of VS2012 I need to use on Windows 8 Enterprise Evaluation? and more importantly where I can find it?

    Thanks,

    Prem


    • Edited by Prem C Thursday, November 22, 2012 9:05 AM
    Thursday, November 22, 2012 9:01 AM

Answers

  • Hi,

    Thanks for the responses.

    I got it working finally, First of all Windows 8 Enterprise Evaluation 32 bit was installed on a 64 bit machine and VS2012 Ultimate RC 64 bit was installed on top of that. May be because of that it wasn't working.

    Later I re-installed the OS with Windows 8 Release Preview 64 bit and VS2012 Ultimate RC 64 bit on top of it and it worked.

    Thanks,

    Prem

    • Marked as answer by Prem C Monday, November 26, 2012 7:33 AM
    Monday, November 26, 2012 7:33 AM

All replies

  • For starters I would update VS2012 to the RTM version and then see what kind of problems you're having. IMHO it's wasted effort troubleshooting an obsolete version of a development environment.

    Thursday, November 22, 2012 4:27 PM
  • I get

    Error    1    Error : DEP0700 : Registration of the app failed. error 0x80070005: windows.licensing failed to update critical data for 3872253e-f148-410d-b786-a3bffb5ee5b0_1.0.0.0_x86__nymeq3yxjx1h6.  Try again and contact the package publisher if the problem persists. (0x80073cf6) 

    Caused by a BSOD (caused by Avira). If you get this, you gotta reinstall windows, there's no fix, it's rather random.

    Monday, November 26, 2012 4:46 AM
  • Hi,

    Thanks for the responses.

    I got it working finally, First of all Windows 8 Enterprise Evaluation 32 bit was installed on a 64 bit machine and VS2012 Ultimate RC 64 bit was installed on top of that. May be because of that it wasn't working.

    Later I re-installed the OS with Windows 8 Release Preview 64 bit and VS2012 Ultimate RC 64 bit on top of it and it worked.

    Thanks,

    Prem

    • Marked as answer by Prem C Monday, November 26, 2012 7:33 AM
    Monday, November 26, 2012 7:33 AM