none
database engine cannot find a record in the table customers with key matching field customernr RRS feed

  • Question

  • on a form I that is in a navigation form , I get this if a leave this form and only partially filled in the form. the customernr (combobox) is not filled in yet

    how can I avoid this error ?

    Tuesday, July 5, 2016 5:51 AM

Answers

  • Hi tekoko,

    Based on this error message, in a one-to-many relationship, you entered data on the "many" side for which there is no matching record on the "one" side. For example, this error occurs if you join a Customers table and Orders table on a CustomerID field, and then add an order using a CustomerID that does not exist in the Customers table.

    Is above description the same with yours? If so, you will need to add matching record on the “one” side. If not, it would be helpful if you could share us your table design with relationship and form design.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Marked as answer by tekoko10 Tuesday, July 5, 2016 7:53 AM
    Tuesday, July 5, 2016 7:42 AM

All replies

  • Hi tekoko,

    Based on this error message, in a one-to-many relationship, you entered data on the "many" side for which there is no matching record on the "one" side. For example, this error occurs if you join a Customers table and Orders table on a CustomerID field, and then add an order using a CustomerID that does not exist in the Customers table.

    Is above description the same with yours? If so, you will need to add matching record on the “one” side. If not, it would be helpful if you could share us your table design with relationship and form design.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Marked as answer by tekoko10 Tuesday, July 5, 2016 7:53 AM
    Tuesday, July 5, 2016 7:42 AM
  • Yes , THX Edward that is the problem

    the form asks first for the date. if the user pushes then  a navigation button the customer number is not filled in yet .

    so I do now a Me.undo on the forms on_error after asking the user if he really wants to leave the form

    is this the right way ?

    the only other thing is , if the user answers yes, the form shows first an empty record and the user has to push the navigation button again .... can this be solved ?

    Tuesday, July 5, 2016 8:03 AM
  • Hi tekoko,

    >>so I do now a Me.undo on the forms on_error after asking the user if he really wants to leave the form is this the right way ?

    I think it's ok to prevent user to lose the data.

    >>if the user answers yes, the form shows first an empty record and the user has to push the navigation button again

    For this new issue, I would suggest you post a new thread, and share us if you do not want an empty record, which record you want to show, a screen shot would be better.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, July 6, 2016 3:17 AM