none
access to Datalake "Manage Access" Blade Fails

    Question

  • Hello, 
    We are suffering a issue when we try to get access to Datalake "Manage Access" Balade, It is curious cause this occurs only on two of the three subscriptions:
     
    Can someone help us?

    Eduard








    • Edited by Micacu Wednesday, November 7, 2018 8:26 AM
    Friday, October 5, 2018 11:14 AM

Answers

  • Hi all!

    Finally the support team found an ACL entry causing this issue, this was the GUID 00000000-0000-0000-0000-000000000000.

    We could not see this ACL entry through the Portal but executing the remove ACL commands the blade shows correctly the access list.

    To remove this entry support told us to execute this:

    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType Group -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType Group -Default -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType User -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType User -Default -Id 00000000-0000-0000-0000-000000000000 -Recurse

    Thanks Jason for everything.

    Regards,

    Eduard.

    • Marked as answer by Micacu Monday, November 19, 2018 3:45 PM
    Monday, November 19, 2018 3:45 PM

All replies

  • Hi

    I have the same error. I have two subscriptions and one works fine, but the other fails with this error.

    Toni

    Friday, October 5, 2018 11:25 AM
  • Hello Eduard,

    Do you have identical permissions to Data Lake across all three subscriptions?  Has this issue only recently appeared?

    Friday, October 5, 2018 9:29 PM
    Moderator
  • Hello Eduard,

    Do you have identical permissions to Data Lake across all three subscriptions?  Has this issue only recently appeared?

    Yes I am owner for the three Datalakes
    Saturday, October 6, 2018 11:52 AM
  • Hi,

    Someone can help us?

    Regards,

    Eduard.

    Monday, October 8, 2018 12:03 PM
  • Hi Eduard, 

    Could you send me an email at AzCommunity@Microsoft.com?  Please remember provide a link to this thread and your subscription ID so we can take a closer look at your resources.  

    Wednesday, October 17, 2018 5:40 PM
    Moderator
  • Hi Eduard, 

    Could you send me an email at AzCommunity@Microsoft.com?  Please remember provide a link to this thread and your subscription ID so we can take a closer look at your resources.  

    I sent you the required info!

    Thanks,

    Eduard

    Monday, October 22, 2018 7:55 AM
  • Hi all!

    Finally the support team found an ACL entry causing this issue, this was the GUID 00000000-0000-0000-0000-000000000000.

    We could not see this ACL entry through the Portal but executing the remove ACL commands the blade shows correctly the access list.

    To remove this entry support told us to execute this:

    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType Group -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType Group -Default -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType User -Id 00000000-0000-0000-0000-000000000000 -Recurse
    Remove-AzureRmDataLakeStoreItemAclEntry -Account **************** -Path / -AceType User -Default -Id 00000000-0000-0000-0000-000000000000 -Recurse

    Thanks Jason for everything.

    Regards,

    Eduard.

    • Marked as answer by Micacu Monday, November 19, 2018 3:45 PM
    Monday, November 19, 2018 3:45 PM
  • Thanks Edu!
    Tuesday, November 20, 2018 10:01 AM