locked
EDMX support for SQL 2000 RRS feed

  • Question

  • Hi All ,

    I am in  in process of reqwriting old application. I have SQl 2000 as backend. When I try to add a new EDMX file against a database , it gives an error that " Only SQL 2005 or next version are supported" . I am doing development in VS 2010.

    Is there any wayout to use edmx in VS 2010 against SQL 2000 apart from upgrading database to SQL 2005.

    Thanks

    Siddhesh


    Siddhesh Sawant

    Monday, March 12, 2012 7:21 AM

Answers

  • Hi Siddhesh S,

    Welcome to MSDN Forum.

    Entity Data Model Designer cannot interact with SQL Server 2000. This is not a limitation of Entity Framework’s
    design tools but Visual Studio 2010 itself. None of Visual Studio’s tools recognizes SQL Server 2000. However, the Entity Framework runtime can.

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Siddhesh S Wednesday, March 14, 2012 11:47 AM
    Wednesday, March 14, 2012 4:28 AM