none
The SQL Server request for username and password every time I want log to my Access program RRS feed

  • Question

  • I migrated my Access database to SQL and now I have an Access software as front-end application and SQL as back-end database. All things are good but I don't know why when I save my Access application as ACCDE in my laptop and move it to end user pcs the sql request for username and password every time the users want to log in. I created and ODBC file and relinked the tables but it didn't work.

    How can I eliminate this log in and save the password ?


    Karim Vaziri Regards,

    Saturday, April 7, 2018 3:59 AM

All replies

  • Hi Karim,

    When you created the linked tables, did you check the box to save the password? If so, you might try using a DSN  less connection.

    Hope it helps... 

    Saturday, April 7, 2018 2:37 PM
  • Dear Dbguy,

    I don't see any check box for saving password!


    Karim Vaziri Regards,

    Sunday, April 8, 2018 3:36 PM
  • What do you see if you click on "Options>>"?
    Sunday, April 8, 2018 4:06 PM
  • Click the OK button on the SQL Server Login dialog. You will see the Save password option in the Link Tables dialog:


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, April 9, 2018 1:05 PM
  • Hello kvaziri,

    What's the current state of the thread? Does theDBguy or Paul's suggestion work for you?

    Has your original issue been resolved? If it has, please mark helpful reply to close the thread. If not, please follow up to let us know the current issue.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 10, 2018 2:24 AM
  • Dear Paul,

    I deleted all linked table and linked them again to SQL and selected the Save Password button, but unfortunately it didn't work.


    Karim Vaziri Regards,

    Monday, April 16, 2018 6:54 AM
  • Dear Paul,

    I deleted all linked table and linked them again to SQL and selected the Save Password button, but unfortunately it didn't work.


    Karim Vaziri Regards,

    Did you enter a user ID and password when connecting to SQL Server?

    When you selected the tables and checked the Save password option did you see the below warning after clicking on the OK button?


    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, April 16, 2018 1:05 PM
  • Yes, I see it but I should tell you that I am in a domain and the SQL Server is on a server. In my home PC that the SQL is local instance I don't have any problem. When I transfer the ACCDE file to my work or to end users' computers the program ask for SQL username and password every time the users try to log in.

    Karim Vaziri Regards,

    Monday, April 16, 2018 2:33 PM
  • Hi,

    I think this makes sense. Since you're linking to a different SQL Server instance at home than at work, you will probably have to relink the database once you install it at work.

    So, when you deploy the database at work, have you tried relinking the tables to the SQL Server instance on the company's server?

    Just curious...

    Monday, April 16, 2018 3:24 PM
  • Yes, I relink the tables at the first install, but when the user log out and exit access, when she/he wants to open the program again, SQL wants the sa password again.

    Regards


    Karim Vaziri Regards,

    Monday, April 16, 2018 3:54 PM
  • Yes, I relink the tables at the first install, but when the user log out and exit access, when she/he wants to open the program again, SQL wants the sa password again.

    Regards


    Karim Vaziri Regards,

    Okay, so when you relink the tables at work, do you check the box to save the password? If so, your server administrator might have some policy enforced to request the password again (just a guess).

    Just a thought...

    Monday, April 16, 2018 4:01 PM