none
Validation error in Windows Phone Store

    Question

  • I have a application on Windows Phone 7.1 which is actually on windows phone store. Now I would like to update. My new app is on Windows Phone 8.1. When i try upload .appx file, i get error:

    1046: We're only certifying apps that target Windows Phone OS 6.3.1 at this time. Submit your app again when you hear from us that we're ready to support this version.

    What I'm doing wrong?

     PS: Sorry for my English :)
    Monday, December 22, 2014 7:18 AM

Answers

All replies

  • While I have not encountered the error myself yet I have the following guess on what's going on. You are trying to upload the .appx package as an update for the old .xap package. That however can't be replaced as it's targeting another version.

    So what should work is the following:

    • create a new update for your App (in Windows Phone Dev Center)
    • Select "Upload and describe your packages"
    • Instead of updating one of the existing packages select "Add new" beneath the list

    The rest of the upload/certification process should be the same. The new App Package should only be available to users of WP8.1 while everyone else will still receive the WP7 version. This also means that WP8.1 users who currently use the WP7 version will be updated to the WP8.1 version (so you should make sure that the new version still works with the data left behind by the WP7 version).

    Hope that helps. If you still encounter the issue it would be great if you could write what steps you are taking exactlly that lead you to the error message you are seeing.

    Monday, December 22, 2014 3:47 PM
  • Hello Natalia,

    If you are still having issues submitting your app please contact Dev Center Support.

    -Miles



    Windows and Windows Phone Dev Center Support

    Send us your feedback about the Windows Platform

    Friday, December 26, 2014 7:29 PM
    Moderator