none
Obfuscated Code Doesn't Run !!? RRS feed

  • Question

  • Dear Friends,

    I Have a C# solution with 2 exe projects and 4 dlls projects.

    After I obfuscate my files, It Douesn't run at all.

    Does any body can help me? Am I add any additional code to my solution?

    In advanced, thank you for your kindness.

    • Moved by spacewrangler Tuesday, November 2, 2010 3:34 PM (From:Building Development and Diagnostic Tools for .Net)
    Sunday, October 31, 2010 1:33 PM

Answers

  • Hi,

    I am writing to check the status of the thread. Here's an article addressing what obfuscation is and how to use dotfuscator to do it. Hope it helps.


    Please mark the right answer at the right time.
    Thanks,
    Sam

    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Friday, November 5, 2010 10:11 AM
  • Hi,

    Yip that sounds about right.You need to be very careful when you obfusticate code. Very careful indeed. You need to start small, a namespace or even just a class at a time, and build it up. Don't expect 100% obfustication, if you get 70% your doing well. It takes a little while and it needs to be fully tested!!


    …we each have more potential than we might ever presume to guess. (Blog: http://dsmyth.blogspot.com/)
    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Friday, November 5, 2010 10:40 AM
  • An possible workaround is to Merge all the assemblies in a single one and obfuscating this merged one. It will solve the problem. Microsoft has a free assembly merge utility on MSDN downloads.

     

    Good luck


    ...
    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Monday, November 8, 2010 7:36 PM

All replies

  • Hi,

    Thanks for your post. Could you provide some more details so others could help you better. How did you obfuscate your code? What's the symptom when your code failed to run? Any exceptions or something?


    Please mark the right answer at the right time.
    Thanks,
    Sam
    • Marked as answer by SamAgain Friday, November 5, 2010 10:19 AM
    • Unmarked as answer by SamAgain Friday, November 5, 2010 10:19 AM
    Monday, November 1, 2010 8:36 AM
  • Hi,

    I am writing to check the status of the thread. Here's an article addressing what obfuscation is and how to use dotfuscator to do it. Hope it helps.


    Please mark the right answer at the right time.
    Thanks,
    Sam

    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Friday, November 5, 2010 10:11 AM
  • Hi,

    Yip that sounds about right.You need to be very careful when you obfusticate code. Very careful indeed. You need to start small, a namespace or even just a class at a time, and build it up. Don't expect 100% obfustication, if you get 70% your doing well. It takes a little while and it needs to be fully tested!!


    …we each have more potential than we might ever presume to guess. (Blog: http://dsmyth.blogspot.com/)
    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Friday, November 5, 2010 10:40 AM
  • An possible workaround is to Merge all the assemblies in a single one and obfuscating this merged one. It will solve the problem. Microsoft has a free assembly merge utility on MSDN downloads.

     

    Good luck


    ...
    • Marked as answer by eryang Friday, November 26, 2010 3:36 AM
    Monday, November 8, 2010 7:36 PM