locked
SQL Server 2012 Report Builder V3 subreport Data Retrieval failed for the subreport RRS feed

  • Question

  • I am trying to create a report with a sub report in Sql Server 2012 using Report Builder Version 3.  I can run the subreport without any problems.  I read where using a shared connection can cause this error so both the main report and the subreport use a connection that is embedded in my report.  

    For testing, I created the subreport without a parameter and added it to the main report.  When I ran it that way, the report worked and sub report displayed the data.  So I know it can read from the database.

    It seems to only give me this error when I am trying to tie the two reports together using a parameter.  

    Has anyone seen this before.  I can send screenshots of any of my setup if needed.

    Thanks for any assistance.

    Tuesday, November 3, 2015 5:18 PM

Answers

  • Hi HalfADozenDad,

    According to your description, when you add a subreport without parameter passed, both main report and subreport can return data. But when you pass parameters from main report to subreport, there will display an error, right?

    In Reporting Services, to pass parameters from main report to subreport, we can open the Parameter tab in Subreport Properties, type the name of a parameter in the subreport for Name. The parameter name must match the name of a report parameter. The Value section can be static text or an expression pointing to a field or other object in the main report. For detail steps, please refer to articles below:
    How to: Add a Subreport and Parameters (Reporting Services)
    Lesson 17: SSRS Subreports

    In your scenario, you can follow the steps mentioned in above articles to pass parameters to subreport. If issue persists, please share some screenshots about report design for our analysis.

    If you have any question, please feel free to ask.

    Best regards,
    Qiuyun Yu


    Qiuyun Yu
    TechNet Community Support


    Wednesday, November 4, 2015 7:58 AM

All replies

  • Hi HalfADozenDad,

    According to your description, when you add a subreport without parameter passed, both main report and subreport can return data. But when you pass parameters from main report to subreport, there will display an error, right?

    In Reporting Services, to pass parameters from main report to subreport, we can open the Parameter tab in Subreport Properties, type the name of a parameter in the subreport for Name. The parameter name must match the name of a report parameter. The Value section can be static text or an expression pointing to a field or other object in the main report. For detail steps, please refer to articles below:
    How to: Add a Subreport and Parameters (Reporting Services)
    Lesson 17: SSRS Subreports

    In your scenario, you can follow the steps mentioned in above articles to pass parameters to subreport. If issue persists, please share some screenshots about report design for our analysis.

    If you have any question, please feel free to ask.

    Best regards,
    Qiuyun Yu


    Qiuyun Yu
    TechNet Community Support


    Wednesday, November 4, 2015 7:58 AM
  • Hi,

    On a Report Server configured in SharePoint integrated mode, when we specify a path for an external item in a dialog box for subreport, we should specify the report name in an expression, with the full URL of the item and the file extension .rdl. For example, ="http://server/site/library/folder/Report1.rdl".

    For more information about specifying paths to external items, please see:
    http://technet.microsoft.com/en-us/library/dd220423(v=sql.110).aspx

    The following thread is about the same issue, you can take as reference:
    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/47426c5a-47df-4817-ad35-7bd5bc1609f3/


    Please Dont forget to mark as answer and Helpful Post. It helps others to find relevant posts to the same question. Milan Das

    Wednesday, November 4, 2015 9:04 AM