locked
Unit Test not discovered after migration the project solution to VS 2013 from VS 2012 RRS feed

  • Question

  • Hi,

    I'v migrated the VS 2012 solution to VS 2013, aftermath the unit test are not discovered in any ways, i tried buil and Clean the project, try Test->windows-> Test Explorer

    But no luck. However, solution build successful. Can someone please help me out.? 


    Tuesday, April 15, 2014 8:44 PM

Answers

  • Hi Ahsan,

    Thank you for posting in the MSDN forum.

    To narrow down this issue:

    (a)We have to make sure that your VS2013 supports the test project, so you could create a simple unit test, check it again.

    (b) Create a simple unit test project in VS2012, and then update it with VS2013, check it again. If it worked well, so we could make sure that it is not the Environment issue.

    (c)If all unit test projects have the same issue, please install the VS2012 Update 4 for VS2012, please also install the VS2013 update 2 RC for your VS2013, and then test it again. If the same unit tests worked well in other VS2013 Environment, please re-pair your VS.

    (d) If a simple unit test project worked well, to make sure that it is not your project files issue, my suggest is that you could create a new solution, and then copy the project files to the new solution in VS2013, check it again. Maybe you could delete the .suo file in your project path, and then re-open it with VS.

    If there's any concern, please feel free to let me know.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, April 16, 2014 9:01 AM