AppId {000C101C-0000-0000-C000-000000000046} Event 10016 problem RRS feed

  • Question

  • Hi,


    I'm running SP2010 on Server2008R2 (HyperV) and SQLServer2008 (also on HyperV).


    I'm getting the following error message:


    Log Name:      System
    Source:        Microsoft-Windows-DistributedCOM
    Date:          2010/08/11 12:51:57 AM
    Event ID:      10016
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          md\SPAdmin
    Computer:      Cut
    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
     and APPID
     to the user md\SPAdmin SID (S-1-5-21-645899720-1558715056-2934291029-1105) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
        <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
        <EventID Qualifiers="49152">10016</EventID>
        <TimeCreated SystemTime="2010-08-10T22:51:57.000000000Z" />
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Security UserID="S-1-5-21-645899720-1558715056-2934291029-1105" />
        <Data Name="param1">machine-default</Data>
        <Data Name="param2">Local</Data>
        <Data Name="param3">Activation</Data>
        <Data Name="param4">{000C101C-0000-0000-C000-000000000046}</Data>
        <Data Name="param5">{000C101C-0000-0000-C000-000000000046}</Data>
        <Data Name="param6">md</Data>
        <Data Name="param7">SPAdmin</Data>
        <Data Name="param8">S-1-5-21-645899720-1558715056-2934291029-1105</Data>
        <Data Name="param9">LocalHost (Using LRPC)</Data>

    I've tried to correct the permissions on the pattern of http://www.mattgrovesblog.com/2009/10/dcom-error-10016-with-sharepoint-2010.html

    (I've used this procedure to get rid of the exact problem described in this blog)

    But after doing the Regedit, I still don't have the rights to set permissions in dcomcnfg.

    How can I correct this?

    It might or might not be related - but I have problems with User Profile Synchronization.










    Wednesday, August 11, 2010 4:32 PM


All replies

  • Hi,

    Have you tried this ?


    I hope this will help you.


    Shafaquat Ali

    M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2, Phone: +923008210320
    • Marked as answer by GuYuming Sunday, August 22, 2010 8:06 AM
    Wednesday, August 11, 2010 6:14 PM
  • What you need is this http://www.wictorwilen.se/Post/Fix-the-SharePoint-DCOM-10016-error-on-Windows-Server-2008-R2.aspx :)

    Alpesh Nakar's Blog Alpesh Just SharePoint Just SharePoint Updates

    SharePoint Conference Southeast Asia Oct 26-27 2010 Contributing Author SharePoint 2010 Unleashed

    MCTS: SharePoint 2010 Configuration MCITP: SharePoint 2010 Administrator

    • Marked as answer by GuYuming Sunday, August 22, 2010 8:06 AM
    Thursday, August 12, 2010 1:35 AM
  • Hi Guys,

    I know this is an old call but thought this was worth adding. The 10016 event above {000C101C-0000-0000-C000-000000000046} is slightly different to the one in the two solutions {61738644-F196-11D0-9953-00C04FD919C1}. It can be resolved using the steps below.

    1.  From the Start search window enter regedit and from the list of options right click regedit and select run as administrator
    2.  Navigate to the HKEY_CLASSES_ROOT\AppID\{000C101C-0000-0000-C000-000000000046}
    3.  Right click the key, select Permissions and click Advanced
    4. Select the Owner tab, set the owner to the Administrators group, tick replace owner on subcontainers and click OK
    5. Grant the administrators group full control permissions and click OK
    6. From the Start search window enter dcomcnfg and from the list of options right click dcomcnfg and select run as administrator
    7. Expand Component Services – Computers – My Computer – DCOM Config
    8. Right Click {000C101C-0000-0000-C000-000000000046} and select Properties  
    9. Select the Security tab click Edit for Launch and Activation Permissions
    10. From Launch Permissions click Add
    11. Click Locations, select the Local Server and Click OK 
    12. Add the WSS_WPG and WSS_Admin_WPG groups and click OK
    13. In the permissions for username select Allow for Local Launch and Local Activation and click OK twice

    This should stop the error occurring.




    • Edited by DaveHDub Monday, January 30, 2012 2:26 PM
    • Proposed as answer by DaveHDub Tuesday, September 10, 2013 8:20 PM
    Monday, January 30, 2012 2:25 PM
  • You have to run component service as Admin via the right click.
    Saturday, March 24, 2012 2:51 PM
  • Dave, thanks so much for your post! Nothing better than step-by-step instructions!

    Cheers back atcha!


    Wednesday, August 1, 2012 3:57 PM
  • Thanks for the detailed instructions, it worked for me and I learned something that will help in the future.
    Thursday, July 21, 2016 10:29 PM