locked
differences between simulator and real surface table RRS feed

  • Question

  • Hello,

    I develop a game for Microsoft surface and when i test this on the simulator all his ok but when i launch it on the real table a problem appear.

    Indeed i have shapes on a scatterview and i lock them when they are on a good position. But on the real table the position change and they are lock in an other location.

    Do you have an idea about why i have this problem ? are there differences between the simulator and the real table ?

    thank you in advance

    ps: sorry for my english i'm french. :-)

    Tuesday, March 23, 2010 3:29 PM

Answers

  • Maybe the problem is really easy to solve.

    Try to change the "WindowStyle" of your SurfaceWindow.xaml to "none", and then set the width to 1024 and the height to 768 (if you didnt do this already)

    I dont know if this is also your problem, but I had this effect when using a grid in the surface window...

     

     

    • Proposed as answer by Tintifax73 Tuesday, March 30, 2010 6:38 PM
    • Marked as answer by April Reagan MSFT Thursday, June 3, 2010 4:03 PM
    Tuesday, March 30, 2010 6:38 PM

All replies

  • How are you checking your positioning?
    Brad Foley | www.blfoley.com
    Wednesday, March 24, 2010 1:27 PM
  • It's in a ScatterView. I check if the center of a ScatterViewItem it's at the same position than a point. So, I compare two points.
    Wednesday, March 24, 2010 1:44 PM
  • Hrm...

    I haven't run across this before, Can you share with us a little about your environment, are you using standard resolutions, etc?


    Brad Foley | www.blfoley.com
    Thursday, March 25, 2010 3:17 AM
  • I use standard 1024x768 resolution for surface application. I think i don't have a special environnement, i use Vista. It's odd because i have a shape on the scatterview at the good location and others shapes should go at the good location on this shape. But they don't go on this shape but next to it. I don't understand because if points change in the real surface why the first shape is at the good position :-/.
    Thursday, March 25, 2010 11:37 AM
  • nobody for help me ? :-(
    Sunday, March 28, 2010 12:28 PM
  • Do you have a sample to reproduce, then I can try it on my table to see if it is happen too.
    Your experience is build from the one of others
    Tuesday, March 30, 2010 8:11 AM
  • Yes, i have a sample if you want i can send it to you ?
    Tuesday, March 30, 2010 3:48 PM
  • Maybe the problem is really easy to solve.

    Try to change the "WindowStyle" of your SurfaceWindow.xaml to "none", and then set the width to 1024 and the height to 768 (if you didnt do this already)

    I dont know if this is also your problem, but I had this effect when using a grid in the surface window...

     

     

    • Proposed as answer by Tintifax73 Tuesday, March 30, 2010 6:38 PM
    • Marked as answer by April Reagan MSFT Thursday, June 3, 2010 4:03 PM
    Tuesday, March 30, 2010 6:38 PM
  • Thank you for you answer

    You think that i should to do this ?

    <s:SurfaceWindow x:Class="ScatterTangram.SurfaceWindow1"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:s="http://schemas.microsoft.com/surface/2008"
        Title="ScatterTangram" Width="1024" Height="768" WindowStyle="none">

     

    Tuesday, March 30, 2010 6:56 PM
  • yets you can send your sample app then I will check if I can reproduce what you said.

    Do not forget to clearly describe sequence of order if needed in order ti get same approach.

    Send it to serge_calderara@hotmail.com

    regards

    serge


    Your knowledge is enhanced by that of others.
    Tuesday, March 30, 2010 8:57 PM
  • You can contact me through my website if you want me to take a look at the code.

    ~Brad


    Brad Foley | www.blfoley.com
    Wednesday, March 31, 2010 12:16 AM