locked
Windows 8, Visual Studio 2012 (30 day eval) and Xamarin RRS feed

  • Question

  • User9050 posted

    Hi There. I am having problems installing Xamarin for Visual Studio 2012. I am running windows 8 64bit with Visual Studio 2012 (30 day Eval copy). When I run the XamarinInstaller.exe file then it installs everything. There are no errors. I can open Xamarin Studio perfectly. When I open visual studio and try to create a new Android project, there are no templates for Android or IOS. When I go to the c:\ in explorer, I see that there are a bunch of new folders (VS2012ROOTFOLDER, VS2012PROJECTTEMPLATESDIR, VS2012ITEMTEMPLATESDIR, VS2012EXTENSIONSDIR, VS2010PROJECTTEMPLATESDIR and VS2010ITEMTEMPLATESDIR) put there by the xamarin installer. What am I doing wrong?

    Monday, April 22, 2013 1:36 AM

All replies

  • User9597 posted

    Same exact issue here. Except I am using VS2012 ultimate.

    Wednesday, April 24, 2013 4:11 PM
  • User9597 posted

    I was able to solve the problem by running the monotouchactivation application on my Mac build machine, and select trial iOS activation. Went back to VS 2012 logged out of my Xamarin account, closed and re-opened VS2012, logged back into my Xamarin account and then created a new iOS iPhone app and it picked up the license.

    Wednesday, April 24, 2013 8:05 PM
  • User51 posted

    Hi,

    The folders in root are a created by WiX (they are names of variables referring to location VS folders for various versions) if the corresponding version of VS is not installed (it's a bug in WiX which we haven't found a work-around to yet). Chris, it might appear that WiX doesn't detect your VS 2012 installation for some reason. Note that you need VS Professional edition at least to use it with Xamarin.{iOS,Android}

    Adam, your case would probably be solved if you just logged out and back in inside VS - it would have activated the server side for you the first time you contacted that build server.

    Thursday, April 25, 2013 6:03 AM
  • User9050 posted

    Hi there, I was told by Xamarin support to try the following which worked.

    Please download and install packages shown below in the order listed:

    Android Components:

    1. JDK 1.6: http://download.xamarin.com/Installer/MonoForAndroid/jdk-6u39-windows-i586.exe

    2. Android SDK: http://dl.google.com/android/installer_r21-windows.exe

    3. GTK#: http://download.xamarin.com/Installer/gtk-sharp-2.12.20.msi

    4. Xamarin Studio: http://download.xamarin.com/studio/Windows/XamarinStudio-4.0.msi

    5. Xamarin.Android for Visual Studio and Xamarin Studio: http://download.xamarin.com/MonoforAndroid/Windows/mono-android-4.6.00049.msi

    You can skip steps 3 and 4 if you don't need/want to use Xamarin Studio and use VisualStudio (2010/2012 Professional or better) instead. In that case you must have VS installed before proceeding with step 5.

    Thursday, April 25, 2013 6:27 AM
  • User9843 posted

    I actually got it to install with VS2012 Premium, which I think is worse than "Professional."

    Saturday, April 27, 2013 5:26 PM