none
Is there an updated EWS API for Exchange 2010 SP3? RRS feed

  • Question

  • Hi Folks,

    I'm using EWS 1.2.1, The ExchangeService constructor takes an exchange version parameter - the highest is ExchangeVersion.Exchange2010_SP2.    Just wondering if there is or is-going to be an update to allow for Exchange 2010 SP3.

    Regards.

    Andy

    Friday, February 15, 2013 3:31 AM

Answers

  • Hello Andy,

    The schema version indicates the minimum server version that supports the functionality described by the schema. We didn't add a 2010_SP3 version since the schema didn't change.

    With regards,


    Michael | Microsoft Exchange Developer Content

    The Exchange Development Forum Guide has useful information for using the Exchange Development Forum.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by AndyW2007 Tuesday, March 19, 2013 8:15 PM
    Tuesday, March 19, 2013 6:49 AM
    Moderator

All replies

  • Just bumping this - in case EWS has been updated.

    Monday, March 4, 2013 8:58 PM
  • Hello AndyW2007,

    There are no schema-based changes for EWS in Exchange 2010 SP3. The only changes that I know that can impact EWS is a change to how the throttling budget is calculated for Exchange impersonation scenarios and a coexistence scenario where an E14 CAS (SP3) can access an E15 mailbox.  

    With regards,


    Michael | Microsoft Exchange Developer Content

    The Exchange Development Forum Guide has useful information for using the Exchange Development Forum.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, March 13, 2013 11:12 PM
    Moderator
  • Hi thanks for your reply,

    I guess I was just trying to determine if one would get version errors, for example, specifying ExchangeVersion.Exchange2010_SP2 because that is the only option, but having it fail because the version is actually SP3.

    Regards

    Andy

    Monday, March 18, 2013 9:54 PM
  • Hello Andy,

    The schema version indicates the minimum server version that supports the functionality described by the schema. We didn't add a 2010_SP3 version since the schema didn't change.

    With regards,


    Michael | Microsoft Exchange Developer Content

    The Exchange Development Forum Guide has useful information for using the Exchange Development Forum.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by AndyW2007 Tuesday, March 19, 2013 8:15 PM
    Tuesday, March 19, 2013 6:49 AM
    Moderator
  • Hi thanks for that,  it was what I was assuming, I just couldn't find any definitive text saying so and I am not keen on making assumptions in code.

    Regards

    Andy

     
    Tuesday, March 19, 2013 8:15 PM