none
Check box doesn't work in Outlook Form RRS feed

  • Question

  • I created an Outlook form that has a few check boxes on it.  I have published the form and was doing some testing on it.  When i check the check boxes and then email the form the check boxes do not stay checked.  I dont know what I am doing wrong or what value they should be set at.  Any help is appor3eciated.
    Wednesday, March 28, 2012 4:49 PM

Answers

  • First, if you are using a customized IPM.Note form and sending it over the Internet (outside of your Exchange org), there's a large risk that the e-mail's message class and/or form definition will be reset or unusable.

    I would add code to the Item_Open event just to verify that your custom form is working.  Also, if you do have code in the form, please show it. Same with any formulas that may be bound to the control or field.

    Also keep in mind that custom e-mail forms have separate Compose and Read layouts that have to be handled differently.


    Eric Legault
    MVP (Outlook)
    About me...

    Wednesday, March 28, 2012 7:23 PM
    Moderator

All replies

  • Have you bound the controls to a custom field?  Is the form published to the Personal Forms library for the person who has been e-mailed your custom form?

    Eric Legault
    MVP (Outlook)
    About me...

    Wednesday, March 28, 2012 6:36 PM
    Moderator
  • I do not know what Vlaue to bond the check box to.  The Form is published in my Personal Forms library
    Wednesday, March 28, 2012 6:55 PM
  • I don't know what you want to bind the check box to either!  But if you need to store the checked state of the check box, you have to store the value in a built-in field or a custom field.  You can choose which field to bind it to with the "Choose Field" selector on the Value tab of the control's property page.

    See here for a kick-start if you're new to custom forms:

    Microsoft Outlook Custom Forms:
    http://www.outlookcode.com/article.aspx?ID=35


    Eric Legault
    MVP (Outlook)
    About me...

    Wednesday, March 28, 2012 7:10 PM
    Moderator
  • i get that I have to bind it to something.  However it doesnot behave properly.  All I need it to do is hold the check mark I have tried using built in fields and creating my own I just can't seem to get the right combo down...any suggestions

    Wednesday, March 28, 2012 7:15 PM
  • First, if you are using a customized IPM.Note form and sending it over the Internet (outside of your Exchange org), there's a large risk that the e-mail's message class and/or form definition will be reset or unusable.

    I would add code to the Item_Open event just to verify that your custom form is working.  Also, if you do have code in the form, please show it. Same with any formulas that may be bound to the control or field.

    Also keep in mind that custom e-mail forms have separate Compose and Read layouts that have to be handled differently.


    Eric Legault
    MVP (Outlook)
    About me...

    Wednesday, March 28, 2012 7:23 PM
    Moderator