none
AdminConsole get Timeout Error when activate SSL RRS feed

  • Question

  • Hi all,

    We have developped some workflows on developpment Environement, and we activated SSL on it successfuly, and we modified all Web.config files of WCF Services, and we tested successfully, but when we installed the Production Environement with SSL Activated, and before deploying the workflows, we get a timeout error in the adminconsole, it belong to the WCF Service, when we check the error message: we found that the admin console calls the WCF service over HTTP instead of HTTPS:

    "http://CCF:443/Microsoft.ccf.csr.webservices.adminConsole/AgentWS.svc" Timeout Exception

    Note that it uses HTTP instead of HTTPS, when we past this URL in the Web Browser, it generate the same error, but when we replace http by https it works.

    Can any one tell me how to resolve this problem, and force AdminConsole to call Webservices over https?

    Thanks

     

     


    Jarjor
    Wednesday, June 23, 2010 10:56 AM

All replies

  • I believe you need to modify the endpoints in the mmc.exe.config in the C:\Program Files\Microsoft CCF 2009\Administrative Tools directory from http to https.
    Wednesday, June 23, 2010 11:59 AM
  • Hi Beumer,

    Thank you for you answer, i already modified the mmc.exe.config in both of Administrative Tools folder and Windows/system32 folder, and still get error, i did one thing, i modified the name of the server, i replace it by "xxxxx" just to test if it use the web config file of admin console, so i gave "http://xxxxx:443/Microsoft.ccf.csr.webservices.adminConsole/AgentWS.svc", i replace it in the Web.Config File of AdminConsole WebService, and in the Two Folder of mmc.exe.config, but when i test, i get the same Error "http://CCF:443/Microsoft.ccf.csr.webservices.adminConsole/AgentWS.svc" Timeout, with the old server name "CCF", for me it seems that it does not use the configuration files?

    Any suggestion?

    Thanks


    Jarjor
    Wednesday, June 23, 2010 12:20 PM