New Flight 14936 Released RRS feed

  • General discussion

  • We have released a new flight with the build number 14936 for insiders. If you discover any new issue, please report it using the feedback app.

    New this build: 

    • This build includes new APIs (Windows.Devices.Gpio.GpioInterruptBuffer) for precisely and efficiently measuring pulse widths using GPIO interrupts.
    • This build addresses issues seen in the file explorer by disabling the search indexer. 
    • Updated OS files including core OS bug fixes

    Known issues: 

    • BluetoothLE pairing may fail on all devices. The cause is under investigation.
    • BluetoothLE GATT service discovery may fail on all platforms
    • Remote Display may fail with the Dragon Board.Remote Display may fail with the Dragon Board.
    Thursday, September 29, 2016 6:13 PM

All replies

  • 1) MinnowBoard with fresh mSD 14376 update to 14393 . UPDATE: MinnowBoard has finally update to 14936.1000 !!

    2) please where i can find the documentation of the new APIs Windows.Devices.Gpio.GpioInterruptBuffer ?


    • Edited by XPLAB.CAP Saturday, October 1, 2016 8:54 AM
    Friday, September 30, 2016 12:42 PM
  • I flashed an SD card to 14376, placed it in my Pi3 and booted. Then I searched for an update, which started downloading. After the download finished, I rebooted the Pi and the update started. I lasted for some 3 hours. After that, the Pi restarted....only to show a screen that says: Windows failed to start..... Status: 0xc000014c: The Boot Configuration Data for your PC is missing or contains errors....

    Too bad, back to 14393 I guess...


    Friday, September 30, 2016 3:19 PM
  • Hi Anne,

    You state "I rebooted the Pi". You likely rebooted while a write was occurring.  I do not reboot my devices and let them reboot themselves and my updates have applied without issue.



    Monday, October 3, 2016 5:53 AM
  • Hi IoTGirl,

    I did not express myself clear enough: the Pi booted itself after finishing the update. After that, the error occurred. I tried again today: installed 14737, started Windows without a problem, started the upgrade (which again took several hours), the Pi rebooted and again ran into the same error. Before I started the process, I erased my SD card to make sure nothing was on it. After the error occurs, it takes a minute or two before the Pi boots again. This afternoon, I kept the Pi on and after numerous attempts the Windows Logo appeared and Windows booted. After some time, the default app appeared. I managed to deploy my app and started it without problems. However, I needed to reposition the Pi so I closed it down (waiting for the green flashing led on the back of the Pi), pulled the plug and repositioned. After powering up, the error message again appears. I have another SD with 14393 which runs like a charm. 


    Wednesday, October 5, 2016 6:00 PM
  • Hi Anne,

    I have not asked for the update, I just let it apply itself.  the message you are getting is indicating corruption in the boot data and I have only seen that with unexpected shutdown.



    Wednesday, October 5, 2016 6:48 PM
  • @Anne, May be this can help. I face many issues on my 3 pi3 with Raspbian and WinIot due to SD card not working correctly. I can't in any way install OS on Sandisk Ultra microSD and on Kingston microSD. Now I use only Lexar 633x and Sandisk Extreme Pro (32 or 64GB) and I don't face any problem anymore.

    The Sandisk Ultra, anyway, does work fine on the Pi2 board BUT NOT on my PI3 ...

    • Edited by LedoDom Friday, October 7, 2016 3:54 PM
    Friday, October 7, 2016 3:52 PM
  • FYI: I am using SanDisk Ultra 16GB, Samsung Evo 16GB and Transcend 16GB all seem to have no issues and all were purchased within the past year.

    Friday, October 7, 2016 4:58 PM
  • I too use the SanDisk Ultra 16Gb Class 10, several ones to be precise. Fact is that when I download 14376 and boot the Pi, everything is okay. I then wait for the update, see the update process happen and after that process is ready, booting the Pi fails. Happened twice now. So it looks the SD card is okay otherwise 14376 would not have booted either. But I will try another SD card this weekend just to be sure!


    Thursday, October 13, 2016 5:48 PM
  • Hi Anne,

    The only case I know of causing an issue is if power is lost when writing or formatting the SD card.  There are quite a few steps to the update process and a number of write cycles.

    In your case, have you replaced the default app or are you leaving the device alone to complete the update cycle? Did you change the device name or password? 

    We have a known issue that update can reset the device to "OOBE" or out of box experience so if you have made changes these may be wiped away by the update.



    Thursday, October 13, 2016 6:19 PM
  • My DragonBoard 410c based device is no longer showing anything in User Folders \ LocalAppData in the device portal. Is it just me or is it a global bug? It used to work fine until the upgrade.
    Monday, October 17, 2016 9:28 AM
  • Hi All,

    14951 has been released.  Please refer to the latest Insider Build post at https://social.msdn.microsoft.com/Forums/en-US/f2170a43-dd3c-45bd-84fc-471508ba9364/new-flight-14951-released?forum=WindowsIoT .



    Friday, October 21, 2016 4:09 PM
  • Hi,

    I finally managed to boot the Pi from 14931 and upgraded to 14936. However, when the Pi boots, I get the same boot error for about half an hour, during which the Pi tries to reboot every minute or so. Eventually the Pi starts though! So, that is good news.

    I discovered a problem in the Windows Device Portal though. When you go to the file explorer you initially see 4 maps: Cameraroll, Document, LocalAppData and PublicDocuments. I expected to see my own app there as well, but it isn't. When you then click LocalAppData the next page shows the 'Cameraroll' map, again not my own app. If I then click the Cameraroll map, the header says 

    User Folders \ LocalAppData \ IoTCoreDefaultApp_1.0.1608.18000_arm__1w720vyc4ccym

    I don't think that is correct. When I browse the directory structure on the Pi I can see the files that belong to my app (logfiles), so I am sure they are there.....


    Wednesday, November 2, 2016 3:15 PM
  • Hi Anne,

    My Pi that was originally provisioned with 14376 has just updated to 14955.  Not sure where 14936 is coming from.

    There was a known issue with first boot.  Can you try with an SD without your app, let it update to 14955 then add your application?



    Wednesday, November 2, 2016 5:12 PM