none
Escaping Characters in BizTalk EDI RRS feed

Answers

  • It depends on the EDI being used. EDIFACT supports a release character (be default the '?', although this can be redefined in the UNA). X12 does not support the concept.

     

    Wednesday, July 23, 2008 10:28 AM

All replies

  • It depends on the EDI being used. EDIFACT supports a release character (be default the '?', although this can be redefined in the UNA). X12 does not support the concept.

     

    Wednesday, July 23, 2008 10:28 AM
  • Since this is not a feature of X12 it sounds like a good future feature for BizTalk. Having a segment separator of a period will not work if a decimal point in a decimal value like 0.190 or in an email address is in the message. It would be nice if BizTalk could handle this out-of-the-box because otherwise it takes a lot of work to use a segment separator of a period.

     

    Thanks,

    Saturday, July 26, 2008 6:02 PM
    Moderator
  • Yes, this is a new feature that would be coming up in R3.

     

    Tuesday, July 29, 2008 5:57 AM
    Moderator
  • Woohoo! Thats great news. Thanks!

     

    Tuesday, July 29, 2008 11:20 AM
    Moderator
  • I don't understand how R3 can implement an escape character in X12 as the resulting EDI will not be understood by any partner (that's not also using R3).

     

    Tuesday, August 5, 2008 10:22 AM
  • I think the fix is in the BizTalk pipeline processor - the problem is not that a new X12 character or sequence needs to be introduced, but that BizTalk cannot process a segment separator of a period when one also exists in an EDI field. Its more of just adding some processing to handle this without logging segment data errors because of the period in the EDI field.

     

    Thanks,

    Tuesday, August 5, 2008 2:12 PM
    Moderator