none
Connecting to Netezza database.. RRS feed

  • Question

  • I've read at a lot of sites that though there are no .NET data providers for Netezza databases, you can connect using ODBC drivers.. But i can't find any tutorials or suggestions regarding how to do that.. Any kind of suggestion is appreciated. Thanks in advance..
    Wednesday, January 2, 2008 9:44 AM

Answers

  • Netezza uses PostgreSQL relational engine so you could use the native .NET provider for PostgreSQL or use OLE DB because if I understand correctly Netezza is a Datawarehouse engine which means by default it is an OLE DB datasource in the Microsoft platform.  You will need the client software or Netezza connection software and add references to OLE DB in VS2005.  This should get you started.

     

    http://pgfoundry.org/

     

    Thursday, January 3, 2008 12:18 AM

All replies

  • Netezza uses PostgreSQL relational engine so you could use the native .NET provider for PostgreSQL or use OLE DB because if I understand correctly Netezza is a Datawarehouse engine which means by default it is an OLE DB datasource in the Microsoft platform.  You will need the client software or Netezza connection software and add references to OLE DB in VS2005.  This should get you started.

     

    http://pgfoundry.org/

     

    Thursday, January 3, 2008 12:18 AM
  • Thanks a lot for your help.. I'll definitely look into this.. I hope this works..
    Thursday, January 3, 2008 5:33 AM
  • Did this approach end up working? Any feedback on issues or tips as we look at linking SSAS to Netezza?
    thanks
    Sunday, October 11, 2009 6:23 PM
  • After lots of search i just came to know that there is an OLEDB driver is also available from Netezza. I think that would be a better option comparing to ODBC.

    Latest OLEDB package for Netezza is available at their ftp site under

    /Releases/5.0.6/nzoledbsetup.exe

    ** You must have partner access login details to access it.

    **Postgrace SQL provider for ADO.net doesn't work with Netezza.
    Tuesday, February 2, 2010 7:36 AM