locked
Unable to Debug TypeScript in VS2013 RRS feed

  • Question

  • User-190675980 posted

    Any help with TypeScript debuging in VS2013?

    1. "Install the Latest Typescript for Visual Studio" (2013).

    2. Create a project "HTML Application with TypeScript".

    V - at this stage debuging is fine.

    3. Enable Windows Authentication and disable Anonymous Authentication by updating project Properties and web.config.

    X - now TypeScript debuging not working

    message: The breakpoint will not currently be hit. No symbols have been loaded for this document.

    The error on from the Output panel:

    SourceMap http://localhost:16247/app.js.map read failed: The remote server returned an error: (401) Unauthorized.

    Click the link of the map file, you can view the file.

    note: If set breakpoints in the generated .js file, it works.

    Tuesday, February 11, 2014 8:39 PM

Answers

  • User-166373564 posted

    Hi Bob

    Thanks for your feedback.

    I did in "Debug" mode - I think it's the way to 'enable' the debugging.

    Yes, you need enable the dubugging in "Debug" mode.

    But this workaround is not good in a team environment.

    Perhaps you could also consider giving a feedback in Microsoft Connect Site(http://connect.microsoft.com/ ), Microsoft VS team will give positive feedback for this problem. 

    Best regards

    Angie Xu

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, February 14, 2014 12:17 AM

All replies

  • User-166373564 posted

    Hi Bob

    message: The breakpoint will not currently be hit. No symbols have been loaded for this document.

    According to the error message above, I think you need enable source maps in Visual Studio 2013, here is reference for this,

    # Source Map debugging  in Visual Studio:

    http://blogs.msdn.com/b/typescript/archive/2012/11/15/announcing-typescript-0-8-1.aspx

    Best regards

    Angie Xu

    Thursday, February 13, 2014 8:49 PM
  • User-190675980 posted

    Angie,

    I did in "Debug" mode - I think it's the way to 'enable' the debugging.

    It worked if I ticked the project option on the TypeScript Build tab: "Specify root directionary of source maps:", and specified the fulll path. But this workaround is not good in a team environment. It may be a bug of IE/TypeScript/IIS Express.

    Thursday, February 13, 2014 10:35 PM
  • User-166373564 posted

    Hi Bob

    Thanks for your feedback.

    I did in "Debug" mode - I think it's the way to 'enable' the debugging.

    Yes, you need enable the dubugging in "Debug" mode.

    But this workaround is not good in a team environment.

    Perhaps you could also consider giving a feedback in Microsoft Connect Site(http://connect.microsoft.com/ ), Microsoft VS team will give positive feedback for this problem. 

    Best regards

    Angie Xu

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, February 14, 2014 12:17 AM