Common Issues - Connecting (Remote Desktop) to Virtual Machine RRS feed

  • General discussion

  • This posting contains a list of some of the common problems that have been seen in early usage of Windows Azure Virtual Machines. These topics can be used as a guide to resolve some of the most common problems that are likely to occur when first using Windows Azure Virtual Machines

    Potential issues that may be seen:

    1.) Remote Desktop endpoint is missing

    Each virtual machine that is created should have a remote desktop endpoint for the VM at port 3389. If this endpoint is deleted then a new endpoint must be created. The public port can be any available port number. The private port (the port on the VM) must be 3389.

    2.) RDP fails with error: "The specified user name does not exist. Verify the username and try logging in again. If the problem continues, contact your system administrator or technical support."

    RDP connection may fail when there are cached credentials. Please see the following article to resolve this problem: http://www.c-sharpcorner.com/uploadfile/ae35ca/windows-azure-fixing-reconnect-remote-desktop-error-the-specified-user-name-does-not-exist-verif/            

    3.) Failure to connect to uploaded VHD

    When a VHD is uploaded to Windows Azure you must make sure that Remote Desktop is enabled on the VHD and an apporopriate firewall rule is enabled on the VM to open port 3389 (Remote Desktop port)

    Messages posted to this forum are provided "AS IS" with no warranties

    Wednesday, June 6, 2012 8:37 AM

All replies

  • If you're stuck at 'Securing remote connection...' and restarting the VM doesn't work, you should try to change the Size of the VM so that it gets re-provisioned. That helped me.

    'Hans Olav.

    Tuesday, July 3, 2012 11:43 AM
  • I cannot connect trough RDP anymore. So after reading this forum, i tried to change the VM size. I Increased the size from small to medium. 

    But the VM is starting since 1 hour. What to do now? When i delete the vm, and re provision the vm, i lost mij datadisk. For some reasen i aint able to attach a existing disk to a Virtual machine. This happend before. I tried to attach the disk trough the Azure Powershell, but i cannot connect to my subscription for some reason.

    Wednesday, July 11, 2012 9:27 AM
  • I also tried changing the VM size and it has been stuck in "starting" state for 2 hours.
    Tuesday, July 17, 2012 6:53 PM
  • I also can not connect through RDP, it always show "Securing remote connection". Reboot does not help. So I have to delete a vm and re-create a new one.
    Saturday, July 21, 2012 3:31 PM
  • Hey Siqi,

    Did the delete solve your problem? I tried everything:reboot,delete, resize and i still cant connect to my virtual machine.



    Monday, July 23, 2012 10:54 PM
  • Hi, I'm having a problem to access by RDP, it dosen't work! I can access by FTP, our client needs an answere  promptly!!

    Thanks in advance!

    • Edited by FLO_RIVAS Tuesday, July 31, 2012 1:39 PM
    Tuesday, July 31, 2012 1:38 PM
  • you should try to change the Size of the VM so that it gets re-provisioned. That helped me!!!!!!!
    Wednesday, August 1, 2012 12:26 AM
  • Have you been able to RDP to this or other VMs previously, or have you not been able to connect to any of the VMs? If you are unable to connect to any VM and you are connecting from behind a firewall then the issue may well be the firewall.

    If you are able to connect to some VMs then please let me know if changing the size resolved the problem.

    Messages posted to this forum are provided "AS IS" with no warranties

    Thursday, August 2, 2012 12:01 AM
  • Yesterday I created my first VM, a 2012 server from gallery.

    The RDP endpoint was created but not responding. I tried

    - restarting the VM, no cure

    - attaching a new 2008 R2 VM, was able to connect to new VM but still not the first

    But after resizing the VM I was immediately able to connect.


    Thursday, September 6, 2012 5:48 AM
  • I also have the same problem - created new VM but can't connect "Remote Desktop can't connect to the remote computer.."
    Friday, September 7, 2012 11:03 AM
  • I am also experiencing this issue with VMs.  It seems to happen if i have not logged into a vm for about a day.  there is nothing to indicate that the server is doing anything in the event log- so i assume the server is locked.  restarting and changing the size of the VM have both worked for me to fix the issue.
    Thursday, September 13, 2012 8:31 PM
  • I also am having this issue. I have delete the VM create a new one, resized it, and same problem. This is a problem because we never had this issue before. Can someone confirm that Microsoft is even aware of this?


    Monday, September 17, 2012 3:36 PM
  • Yes we do have a few RDP connection issues that we are working to resolve. We have a few fixes that will be going out in the next two weeks that should solve some of these issues. If you are still seeing issues after restart and resize then please follow these steps:

      • Start a unique thread in the forum (for our internal tracking)
      • Send email to IaaSForum@microsoft.com with your subscription ID, Deployment ID and a link to the thread.

    Messages posted to this forum are provided "AS IS" with no warranties

    Monday, September 17, 2012 4:30 PM
  • I had the same issue. Resizing the VM to a smaller footprint and resizing back to the one I wanted fixed it.

    Monday, September 17, 2012 9:17 PM
  • None of these suggestions seem to help and I am still unable to connect to my VM.  It's a Windows VM built from the BizTalk 2010 R2 vhd in the Gallery.  Please help!

    Ed Jones, MCPD, MCTS: BizTalk, WCF talentedmonkey@hotmail.com http://talentedmonkeys.wordpress.com

    Wednesday, September 19, 2012 3:03 AM
  • Ed,

    Please follow these steps so that we can provide additional assistance directly with your VM:

    • Start a unique thread in the forum (for our internal tracking)
    • Send email to IaaSForum@microsoft.com with your subscription ID, Deployment ID and a link to the thread.

    This will enable us to see what is happening in your specific instance and get you unblocked.

    Messages posted to this forum are provided "AS IS" with no warranties

    Thursday, September 20, 2012 5:27 AM
  • Yes!! Thank you!

    I reduced the size of VM and then put it back to original size. then it worked!!

    remember -just reducing size did not work but putting it back to original size worked.

    Wednesday, November 14, 2012 7:59 AM
  • I had the same problem and managed to solve it by changing the public port for the RDP-connection.
    Then I was able to connect again.

    Thursday, November 15, 2012 2:57 PM
  • I'm having the same problem, intermittently. After I reboot, it usually works fine. At some indefinite point after that, I can no longer reconnect. I can try reprovisioning (I already did up from Medium -> Large intentionally) if this is a permanent fix, but I can't constantly reset my server to be able to RDP in!

    Any ideas?

    Tuesday, January 15, 2013 2:39 PM
  • I've tried 3 times as well - and can't connect.  Public/Private port are set to 3389 by default (which will never work) - changed the public port to 56300 - but still can't connect.
    Thursday, January 31, 2013 3:45 PM
  • To whom it may concern:

    I tried all of this and nothing helped. Then I found out my VM has been attached 2 Disks. One might have been attached wrongly (most likely automatically) after I created an Availability Set and the VM got restarted. Then I found out which Disk was the wrong one (the one without https) and removed it. Then I was able to remote right away! I hope this helps.

    Friday, January 3, 2014 4:37 AM
  • what seems to be the problem here is that you might need to setup a ACL permit rule to your IP address CIDR.

    in the VM management console, please go to VM-> Endpoint. click on the RDP endpoint, and below you will find a "Manage ACL".

    in the new pop-up window provide the CIDR of your system IP address and assign the permit rule to it.

    you can generate a CIDR from http://www.ipaddressguide.com/cidr. for example my IP address is I gave a CIDR of it worked for me.

    Hope this helps.

    Sunday, September 28, 2014 4:46 AM
  • I accidentally disabled Remote Desktop access while logged in via RDP. Now I can't find a way to turn RDP back on. Is there a method to change RDP session via the portal or azure powershell?

    • Edited by epochdave Tuesday, December 9, 2014 12:52 AM
    Tuesday, December 9, 2014 12:52 AM
  • I could fix it doing the following

    1. Changed the existing Remote Desktop Endpoint private port to something like 3388
    2. Creating a new endpoint, with any public port and pointed to 3388 (not sure if this step is necessary, maybe it doesn't).
    3. Tried to connect to that new connection, didn't work
    4. Deleted the new endpoint. Edited the original one to point again to 3389.
    5. Tried to connect again as normally do, it worked!

    Hope it helps

    Sunday, March 15, 2015 2:04 AM