none
Invalid occurence outside message, package or group issue RRS feed

  • Question

  • Hi guys:

    I'm developing the mapping from EDIFACT to XML, when Biztalk received the file, the file can be mapped correctly(I mean the XML file can be generated correctly), but when I view the application event view, ther are a error says:
     
    33: Invalid occurence outside message, package or group

    Then I going to the Biztalk Administration Console to view the Suspended Servicse Instances, in the Message Details-->Body showing: UNZ+1+20'

    What can I do to fix this error? Thanks.
    Friday, April 24, 2009 6:41 AM

Answers

  • Hi,

    That specific error is thrown if there is some structural error in the EDIFACT mesg that you are trying to convert. Can you check the structure of the mesg manually ? i.e. if UNA is followed by UNB, followed by UNG.. UNH .. UNT .. UNE .. UNZ ?

    I remember ppl seeing the same error when the delimiters are not proper in the EDIFACT mesg. Can you give us the UNA segment of your mesg ? Are you using just LF as a segment suffix by any chance ? Let me check a prev thread where ppl have reported similar issue.

    Regards,
    Kowshik Palivela
    • Marked as answer by Sinosky_Lin Tuesday, April 28, 2009 10:22 AM
    Saturday, April 25, 2009 12:54 PM

All replies

  • Hi,

    That specific error is thrown if there is some structural error in the EDIFACT mesg that you are trying to convert. Can you check the structure of the mesg manually ? i.e. if UNA is followed by UNB, followed by UNG.. UNH .. UNT .. UNE .. UNZ ?

    I remember ppl seeing the same error when the delimiters are not proper in the EDIFACT mesg. Can you give us the UNA segment of your mesg ? Are you using just LF as a segment suffix by any chance ? Let me check a prev thread where ppl have reported similar issue.

    Regards,
    Kowshik Palivela
    • Marked as answer by Sinosky_Lin Tuesday, April 28, 2009 10:22 AM
    Saturday, April 25, 2009 12:54 PM
  • Thanks Kowshik , I think it is the structure issue.
    Tuesday, April 28, 2009 10:23 AM
  • Hi

     

    I have the same error. I compared my Data with the IFTMIN Schema I do not see problems. I even validated the instance on VS and it validates fine. Its just when I throw it on the folder through my pipeline. the data looks as below the CRLF are just for readability

     

    UNB+UNOA:2+BPEDI01+PETROSA+110505:1700+141258'
    UNH+1+OILNOT:D:93A:OI'
    BGM+781+0105763982+9'
    CTA+IC+RICHARD SUNKEL'
    COM+(021) 408-2302:TE'
    DTM+97:201104211227:203'
    DTM+11:201105051131:203'
    LOC+9+440728:37:200'
    LOC+11+240206:37:200'
    LOC+16+000360:200:201'
    TOD++NC'
    RFF+REG:1924/002602/07'
    RFF+LP:97200017'
    RFF+DON:595972010'
    RFF+AAS:8082332464'
    RFF+DQ:1481181'
    RFF+BLN:63982'
    RFF+SUO:89580001481181'
    RFF+ABO:0105763980'
    RFF+ACD:M'
    RFF+FS:::01'
    TDT+1++2+21+15:126:201'
    NAD+CZ+BP'
    NAD+CN+BP'
    NAD+OY+PT'
    NAD+SU+BP'
    NAD+CW+SAV'
    GID+1+1:VL04'
    PIA+5+00128::122:201'
    EQD+RR+38022443'
    MEA+WT++KGM:30459'
    MEA+VOL++LTR:36003'
    MEA+TE++CEL:200'
    MEA+DEN++ZZ:8460'
    MEA+ULL++MMT:64'
    SEL+139115'
    SEL+139116'
    UNT+37+1'

     

    Please help


    Wonder Andile Hlongwane MCTS
    Wednesday, November 16, 2011 9:46 AM