locked
Sharepoint IP IIS bindings issue RRS feed

  • Question

  • Recently, I had the requirement to bind Sharepoint website to a specific IP.

    So I changed the IIS binding to something like this (ip:80:host = 10.10.10.10:80:xxx.com).

    SharePoint stopped working and I am getting 404 not found.

    Is there anything I am missing?

    Thanks

    Omar

    Friday, February 13, 2015 10:39 PM

Answers

  • Hi omirza

    According to the issue you mentioned earlier I can say

    what are the host settings in iis for each site?

    iis -> under sites click on any site -> right hand side click on bindings

    what can you see? do you have a host headed, whats the port? ip address?

    first get central admin so go view that first!

    binding settings:

    i think the port is standard throughout as 42820 type is http ip should be blank (when edit item its all unassigned ips) no host no binding info!

    once done click ok, now back at the site settings on iis, select basic settings below bindings.

    click test settings. if the path is visable and available and the account used for app pool account for central admin than you should get two ticks, if not you need to fix those issues!

    repeat process for all other sites!


    Indul Hassan
    Microsoft Community Contributor
    http://www.indulhassan.com
    You Snooze.. You Lose !!


    • Edited by IndulHassan Monday, February 23, 2015 1:15 PM
    • Marked as answer by Eric Tao Tuesday, March 10, 2015 6:38 AM
    Monday, February 23, 2015 1:13 PM
  • Hi Omirza,

    The binding only works with internal NIC (Network Interface Card) address. If you want to access your website from the Internet you should ask your network team to configure the internet NIC to communicate with the internet NIC. The IP addresses added on LB must be internet NIC. Your network/infrastructure team should know how to do that much better than you.

    Regards,
    -T.s


    Thuan Soldier
    A 23-year-old man loving Microsoft technologies and making crazy ideas on business journey.
    SharePoint Vietnam | Blog | Twitter

    • Marked as answer by Eric Tao Tuesday, March 10, 2015 6:38 AM
    Saturday, February 21, 2015 4:24 AM

All replies

  • Please refer this -

    http://blog.walisystemsinc.com/2012/11/sharepoint-2013-setup-multiple-urls-in.html

    Alternate Access Mappings (AAMs) *Explained

     

    Please 'propose as answer' if it helped you, also 'vote helpful' if you like this reply.

    Saturday, February 14, 2015 12:41 AM
  • You must add entry to the host file. Something likes:

    10.10.10.10 xxx.com

    Then add internet URL to Alternative Access Mapping to avoid wrong URL when accessing website from the Internet.

    Regards,
    -T.s


    Thuan Soldier
    A 23-year-old man loving Microsoft technologies and making crazy ideas on business journey.
    SharePoint Vietnam | Blog | Twitter

    Saturday, February 14, 2015 6:37 AM
  • Hi,

    Your IIS Port: 80 default site must be stopped.

    Saturday, February 14, 2015 4:10 PM
  • Hi Omar,

    1. Check your web applciation AAM(Alternative Access Mapping), make sure the xxx.xxx.com is added as Public URL for a zone, e.g. Internet zone, custom zone, etc.

    2. Check the IIS binding for your SharePoint site, make sure your each value is correct, ip, port number, host name (10.10.10.10, 80, xxx.xxx.com).

    3. Check and make sure the FQDN(xxx.xxx.com) could be resolved to IP Address by your DNS (if not, then Add an A record in your DNS Server) or a public DNS server.

    4. ResetIIS if needed (or reboot the server if possible).

    http://www.mssharepointtips.com/tip.asp?id=1102&page=1


    Thanks,
    Daniel Yang
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Daniel Yang
    TechNet Community Support

    • Proposed as answer by Sudip Misra Monday, February 16, 2015 1:14 PM
    Monday, February 16, 2015 7:44 AM
  • HI Omar,Just of add in the IIS bindings will not work.you need to add the Host entry in the server with IP and AAM of site in sharepoint .Check the below link where to create the Host entries and AAMS.

    http://expertsharepoint.blogspot.de/2013/10/path-for-host-file.html#sthash.8thFKmvS.dpuf

    http://expertsharepoint.blogspot.de/2014/02/explanation-of-zones-in-alternate.html


    Anil Avula[Partner,MCP,MCSE,MCSA,MCTS,MCITP,MCSM] See Me At: http://expertsharepoint.blogspot.de/

    Monday, February 16, 2015 8:14 AM
  • Hi Daniel,

    Thank you for your reply.

    1. I have XXX.XXX.com as the default zone AAM. Does this make a difference

    2. IIS binding is correct

    3. the FQDN resolves to the ip address of the NLB (network load balancer) then the NLB redirects to one of the front end servers. but it does not resolve when I add the ip address to the binding

    Any idea?

    Thanks

    Omar

    Friday, February 20, 2015 4:59 PM
  • Hi Anil

    I have already done those.

    but it is stil not getting resolved outside of the sharepoitn server

    Thanks

    Omar

    Friday, February 20, 2015 5:00 PM
  • 3. the FQDN resolves to the ip address of the NLB (network load balancer) then the NLB redirects to one of the front end servers. but it does not resolve when I add the ip address to the binding

    So if I understand you correctly, the IP address 10.10.10.10 is the address of the NLB? To clarify, this is the Windows Server Network Load Balancer? Can you provide more information about how you've configured this?

    What URL will users use to access the web application? http://10.10.10.10 or a DNS hostname?


    Friday, February 20, 2015 6:04 PM
  • Ok so I have two WFE. lets say 10.10.10.10 and 10.10.10.11.

    They are load balanced by the windows server network load balancer which is 10.10.10.12

    The users browse to sharepoint by typing the following into their browser: http://xxx.xxx.com

    xxx.xxx.com resolves to ip address 10.10.10.12.

    My current IIS bindings are

    WFE1 & WFE2 = (ip:80:host = *:80:xxx.xxx.com).

    ------------------------------------------------------------

    In the host files on both WFEs, I have the following entries

    WFE1: 10.10.10.10 xxx.xxx.xom

    WFE2: 10.10.10.11 xxx.xxx.com

    ------------------------------------------------------------

    The IIS bindings that do not work:

    WFE1: 10.10.10.10:80:xxx.xxx.com

    WFE2: 10.10.10.11:80:xxx.xxx.com

    note that if you browse to  http://xxx.xxx.com from inside the servers, the website loads. Only when you browse from outside the machine, the website doesnot load.

    -------------------------------------------------------------

    Friday, February 20, 2015 6:34 PM
  • Great, thanks for this info.

    OK, so taking a step back, you said it works when you don't bind the IP address in the IIS site. Why are you trying to bind the IIS site to a specific IP address? Can you help me understand this new requirement?


    Friday, February 20, 2015 6:43 PM
  • The IT team wants me to. Is there a reason not to do so?
    Friday, February 20, 2015 6:51 PM
  • Hi Omirza,

    The binding only works with internal NIC (Network Interface Card) address. If you want to access your website from the Internet you should ask your network team to configure the internet NIC to communicate with the internet NIC. The IP addresses added on LB must be internet NIC. Your network/infrastructure team should know how to do that much better than you.

    Regards,
    -T.s


    Thuan Soldier
    A 23-year-old man loving Microsoft technologies and making crazy ideas on business journey.
    SharePoint Vietnam | Blog | Twitter

    • Marked as answer by Eric Tao Tuesday, March 10, 2015 6:38 AM
    Saturday, February 21, 2015 4:24 AM
  • Hi omirza

    According to the issue you mentioned earlier I can say

    what are the host settings in iis for each site?

    iis -> under sites click on any site -> right hand side click on bindings

    what can you see? do you have a host headed, whats the port? ip address?

    first get central admin so go view that first!

    binding settings:

    i think the port is standard throughout as 42820 type is http ip should be blank (when edit item its all unassigned ips) no host no binding info!

    once done click ok, now back at the site settings on iis, select basic settings below bindings.

    click test settings. if the path is visable and available and the account used for app pool account for central admin than you should get two ticks, if not you need to fix those issues!

    repeat process for all other sites!


    Indul Hassan
    Microsoft Community Contributor
    http://www.indulhassan.com
    You Snooze.. You Lose !!


    • Edited by IndulHassan Monday, February 23, 2015 1:15 PM
    • Marked as answer by Eric Tao Tuesday, March 10, 2015 6:38 AM
    Monday, February 23, 2015 1:13 PM