none
Application requires that assembly stdole Version 7.0.3300.0 RRS feed

  • Question

  • We have a custom application being deployed via ClickOnce.  It works on most computers but we have one stubborn machine.  When attempting to run the installation, it returns this error:

    "Unable to install or run the application.  The application requires that assembly stdole Version 7.0.3300.0 be installed in the Global Assembly Cache (GAC) first.  Please contact your system administrator."

    XP Pro (fresh install)
    Office 2003 Pro (complete installation, no installation files deleted after install)
    stdole.dll version 7.0.9466.0

    I tried copying stdole.dll from another PC that was successful with the install.  Same error.
    I tried uninstalling and reinstalling every version of the dang .NET framework (1.0, 2.0, 3.0, 3.5).  Same error.
    I tried manually downloading and installing the Office 2003 Primary Interop Assemblies.  Same error.

    Everything I can find online indicates that stdole needs to be included in the installation rather than listed as a prerequisite.  This would need to be modified in the project in Visual Studio.  I am not the programmer and I do not have access to Visual Studio or the project files.  Unfortunately, since this works on other computers no one thinks it's possible that the problem is the application.

    Some people mentioned trying to register the file using gacutil.exe or regasm.exe but I am unable to find either of these; I suspect they must be part of Visual Studio.

    Update: We were able to get this working by upgrading to Office 2007 and manually installing the Office 2007 Primary Interop Assemblies.  Unfortunately this is only a workaround and isn't really practical for those who don't have spare Office 2007 licenses available.  It also completely defeats the purpose of OneClick installs since a typical installation wizard is an easier process than the PIA.
    Tuesday, March 2, 2010 3:00 AM

Answers

  • Hi Jeremy,

    Thank you for your post.

    For your concern, you might try the workaround mentioned in the following similar issue.
    http://stackoverflow.com/questions/558361/unable-to-install-or-run-the-application-the-application-requires-stdole-version

    Referring to gacutil.exe or regasm.exe, they are the tools of .NET Framework. The .NET Framework tools are included in the Windows Software Development Kit (SDK), which is automatically installed when you install Visual Studio.

    Regasm.exe can generate and register a type library describing the types found in the assembly when you specify the /tlb option.
    For more information on Regasm.exe , see: http://msdn.microsoft.com/en-us/library/tzat5yw6.aspx

    BTW, this forum is for the support of .NET Framework installation. Since your issue is related to ClickOnce, you could post your thread on ClickOnce and Setup & Deployment Projects forum. You will get more useful help there. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.

    Best regards,
    Yichun Chen

    (This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.)
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, March 9, 2010 5:58 AM
    Wednesday, March 3, 2010 7:00 AM