locked
Template: How to make a vsix template Visual Studio Gallery will accept. RRS feed

  • Question

  • I went and made a fantastic WPF Prism Template.  I think it adds some real value over what is currently out there.

    I have tested it extensively and it works great!

    So, I thought, why not share this with my fellow Prism Developers?

    I went to upload it and I got this error:

    Path may be too long in VSIX

    I did some googling and saw something about not having spaces in my folders, files or paths.  OK, I guess I can make that change so that the community can benefit from my work.

    So I took out all the spaces in my folders, files and paths.  But I still get the error.

    I saw somewhere else that I need to be careful that, when installed, my template does not exceed 260 chars.  Well, I am not even close to that, but I went and reduced my template path from:

    ProjectTemplates/Windows/Prism/PrismWPFApplication

    To

    T/Windows/PrismWPFApplication

    But I am still getting the error.  (Note, I have 4 template zips in my vsix, but the example above is the longest named one.)

    So, what do I need to change in my vsix to make Visual Studio Gallery allow me to share my work?  (I have to admit, for a web site that is supposed to allow me to share, it sure is getting in the way a lot.)

    And does any one know what they really mean by "Path may be too long in VSIX"?

    Tuesday, May 22, 2012 10:56 PM

Answers

  • So, to see the full path that it is using you have to go to:

    %LocalAppData%\Microsoft\VisualStudio\10.0\Extensions

    All extensions are listed there.  The full path includes the Extension Name, the Author and Version along with the actual path you want to use.

    I had to get mine below 70 chars before it would be accepted.  YMMV.

    • Marked as answer by Vaccanoll Thursday, May 24, 2012 1:52 AM
    Tuesday, May 22, 2012 11:10 PM
  • Hi Vaccanoll,

    The “Path may be too long in VSIX” means the path length takes into account other operating systems where the length of your templates (and the depth of the templates) will exceed 260 characters after the template cache is created for it.

    Some options:
    - reduce the folder name of where your templates are in (call it "t")
    - reduce the name of the folders and or files in your template zip

    It may work fine on your machine but on other operating systems (such as XP), the path to the localappdata folder gets pretty long.

    According to your description, I think you have figure it out.

    Best regards,

    Lucy


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Vaccanoll Thursday, May 24, 2012 1:52 AM
    Wednesday, May 23, 2012 6:31 AM

All replies

  • So, to see the full path that it is using you have to go to:

    %LocalAppData%\Microsoft\VisualStudio\10.0\Extensions

    All extensions are listed there.  The full path includes the Extension Name, the Author and Version along with the actual path you want to use.

    I had to get mine below 70 chars before it would be accepted.  YMMV.

    • Marked as answer by Vaccanoll Thursday, May 24, 2012 1:52 AM
    Tuesday, May 22, 2012 11:10 PM
  • Hi Vaccanoll,

    The “Path may be too long in VSIX” means the path length takes into account other operating systems where the length of your templates (and the depth of the templates) will exceed 260 characters after the template cache is created for it.

    Some options:
    - reduce the folder name of where your templates are in (call it "t")
    - reduce the name of the folders and or files in your template zip

    It may work fine on your machine but on other operating systems (such as XP), the path to the localappdata folder gets pretty long.

    According to your description, I think you have figure it out.

    Best regards,

    Lucy


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Vaccanoll Thursday, May 24, 2012 1:52 AM
    Wednesday, May 23, 2012 6:31 AM