locked
I'm happy, it's all working RRS feed

  • Question

  • User-486194925 posted

    I didn't get too far with IIS7 and Vista at home, but at work I've got Win2K3 and so IIS6. I installed FastCGI TP2 and got it talking to RoR in half a day. I'm also talking to an MS SQL database. All is good.

    I do have what looks like a session timeout problem. After a few minutes ruby shuts down so the next request takes a while to get going. I think I may not have set my ini file up correctly:

    ExePath=D:\Applications\Ruby\bin\ruby.exe
    Arguments=D:\Data\Rails\myApp\public\dispatch.fcgi
    IgnoreDirectories=0
    IgnoreExistingFiles=1
    QueueLength=1000
    MaxInstances=4
    InstanceTimeout=1200
    ActivityTimeout=3000
    InstanceMaxRequests=200

    It could be the InstanceTimeout, but I haven't found any way of setting this to infinite, which would be ideal for me - I guess I've set it to 20 mins. However another opst indicates this parameter is deprecated.

    It's not a major for me. I'm just happy that I can do Rails under IIS. At home, I'm plodding on with Rails under apache.

    Derek

    Monday, September 10, 2007 9:03 PM

All replies

  • User1538427629 posted

    It may be your InstanceMaxRequests=200

     That setting is how many requests are served by each process before being recycled (started again).  For PHP, a typical setting ranges between 5000 and 10000.

    Wednesday, April 30, 2008 1:18 AM