none
How to keep framework 1.1 and 2.0 on same machine ? RRS feed

  • Question

  •  

    I have visula studio 2003 and framework 1.1 installed on my machine.

    I also have windows XP profeesional with SP2.

     

    I want frmework 2.0 on my machine, but at the same time framework 1.1 should remain.

    Is this is possible ?

    Also for framework 2.0 is it necessary to install Visual studio 2005 ?

     

     

    Friday, January 4, 2008 9:18 AM

Answers

  • Hi,

     

    have visula studio 2003 and framework 1.1 installed on my machine.

    I also have windows XP profeesional with SP2.

     

    I want frmework 2.0 on my machine, but at the same time framework 1.1 should remain.

    Is this is possible ?

     

    Yes. It is possible. You can install different .NET versions on the same machine.

     

     

    Also for framework 2.0 is it necessary to install Visual studio 2005 ?

     

    No. Not required. But the opposite true. You will need to install .NET 2.0 before installing VS 2005.

     

     

    HTH,
    Suprotim Agarwal

    -----
    http://www.dotnetcurry.com
    -----

    Friday, January 4, 2008 9:31 AM
    Moderator

All replies

  • Hi,

     

    have visula studio 2003 and framework 1.1 installed on my machine.

    I also have windows XP profeesional with SP2.

     

    I want frmework 2.0 on my machine, but at the same time framework 1.1 should remain.

    Is this is possible ?

     

    Yes. It is possible. You can install different .NET versions on the same machine.

     

     

    Also for framework 2.0 is it necessary to install Visual studio 2005 ?

     

    No. Not required. But the opposite true. You will need to install .NET 2.0 before installing VS 2005.

     

     

    HTH,
    Suprotim Agarwal

    -----
    http://www.dotnetcurry.com
    -----

    Friday, January 4, 2008 9:31 AM
    Moderator
  • Thanx for that.

     

    But, then how to configure a machine.

    I want to use framework 2.0 to create new application and then later switch to framework 1.1 for existing application.

    For this what seetings needs to be configured ?

    What difficulties I may face while building 2.0 application with VS 2003 ?

    If I installed VS2005 on my machine will my web based application with framework 1.1 work on it ?

     

    Friday, January 4, 2008 11:11 AM
  •  

    Thanx for that.

     

    But, then how to configure a machine.

    I want to use framework 2.0 to create new application and then later switch to framework 1.1 for existing application.

    For this what seetings needs to be configured ?

    What difficulties I may face while building 2.0 application with VS 2003 ?

    If I installed VS2005 on my machine will my web based application with framework 1.1 work on it ?

     

    Friday, January 4, 2008 1:51 PM
  • Dear Amol,

     

    Visual Studio 2003 was not designed to build .NET 2.0 applications.

     

    Build .NET 1.1 applications using VS 2003

    Build .NET 2.0 applications using VS 2005

     

    You can have both versions of Visual Studio on the same machine

     

    Note: VS 2008, the new edition of Visual Studio, gives you the capability to target .NET 2.0, 3.0 or 3.5 applications.

     

     

    HTH,
    Suprotim Agarwal

    -----
    http://www.dotnetcurry.com
    -----

     

    Friday, January 4, 2008 2:27 PM
    Moderator