none
Install Issues with .Net Framework 3.5 on Vista 32 Bit RRS feed

  • Question

  • I am having a hard time installing .net framework 3.5 Sp1 that is pending on my Windows Update. The error below is what I receive. I can also completed all the steps listed below.

    12/10/10,11:45:49] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603

    [12/10/10,11:45:50] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

    [12/10/10,13:54:27] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603

    [12/10/10,13:54:29] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

    Approach 1:

    1. Uninstall all the versions.

    2. Used cleanup tool to make sure that everything is un-installed properly.

    3. Re-install all versions one by one along with the service packs.

    It gave the above error when I install .Net 3.5 sp1.

    Approach 2:

    1. Uninstall all the versions.

    2. Used cleanup tool to make sure everything is un-installed properly.

    3. Tried installing .Net 3.5 sp1.

    It still gave the same error as above.

    Thanks in advance.

    Friday, December 10, 2010 10:01 PM

All replies

  • How did you go about "uninstall all versions"? Vista installs .NET Framework 2.0 + the extension 3.0 as an integral part of the OS. Tools such as Aaron Stebner's framework removal tool are not intended for use with integral frameworks.

    If you have not damaged the 2.0/3.0 integral to Vista, the download you want is this one:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    This is the full cumulative download that will detect any needed prerequisites to 3.5 SP1 and install what's needed, including 3.5 SP1. It's a large download, but downloading then installing locally is nore reliable than web installers IME.

     

    Saturday, December 11, 2010 3:38 PM
  • That is the file I am trying to install and getting the setup.exe error

     

    [12/10/10,13:49:09] Beginning of new SetupVerifier activity logging session
    [12/10/10,13:49:09] Activity log file location: C:\Users\DellXPS\AppData\Local\Temp\setupverifier_main_12-10-10_13.49.09.txt
    [12/10/10,13:49:09] Error log file location: C:\Users\DellXPS\AppData\Local\Temp\setupverifier_errors_12-10-10_13.49.09.txt
    [12/10/10,13:49:09] Build created on October 15, 2010
    [12/10/10,13:49:09] Detected operating system: Windows Vista (x86)
    [12/10/10,13:49:09] Install state for .NET Framework 1.0: not installed.
    [12/10/10,13:49:09] Install state for .NET Framework 1.1: not installed.
    [12/10/10,13:49:09] Install state for .NET Framework 2.0: installed with no service packs.
    [12/10/10,13:49:09] Install state for .NET Framework 3.0: installed with service pack 2.
    [12/10/10,13:49:09] Install state for .NET Framework 3.5: not installed.
    [12/10/10,13:49:09] Install state for .NET Framework 4 Client: not installed.
    [12/10/10,13:49:09] Install state for .NET Framework 4 Full: not installed.
    [12/10/10,13:49:09] Not adding product '.NET Framework 1.0' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 1.1' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 2.0 SP2' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 3.0' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 3.5' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 3.5 SP1' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 4 Client' because it is not currently installed
    [12/10/10,13:49:09] Not adding product '.NET Framework 4 Full' because it is not currently installed

    Saturday, December 11, 2010 5:54 PM
  • Hi xchris5442x,

    Could you please provide more detailed installation log file for me? You can use skydrive upload your log file and share the link in your reply.

    Please feel free to let me know how it goes.

    Best Regards,

    Larcolais


    Larcolais Gong[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, December 14, 2010 11:40 AM