Just in time debugger popup message issue RRS feed

  • Question

  • User-581279704 posted


    In my production, Iam getting the JIT debugger Popup msg frequently due to that server is getting slow and in production I don't have VS but only IIS.

    I tried to fix this issue by using following method

    1. Click on Start Menu and Type Run (for P Hit Run box)
    2. Type in regedit and hit Enter
    3. Expand the Keys to located the place
    4. HKLM\Software\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger is one location.
    5. HKLM\Software\Microsoft\.NETFramework\DbgManagedDebugger
    6. Delete these keys. Or set the Auto key's value to 1.
    7. On a 64bit system the paths will be: HKLM\Software\Wow6432Node\Microsoft\...
    8. You may need to reboot the system as well. 

    • Get a Command Window (Command Prompt)
    • Type drwtsn -i and 
    • Hit enter

    Tuesday, March 1, 2016 6:11 AM


  • User-166373564 posted


    You could disable Just-In-Time debugging by editing the Windows registry.

    To disable Just-In-Time debugging by editing the registry

    1.On the Start menu, search for and run regedit.exe

    2.In the Registry Editor window, locate and delete the follow registry keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger


    3.If your computer is running a 64-bit operating system, delete the following registry keys also:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger


    4.Take care not to accidentally delete or change any other registry keys.

    5.Close the Registy Editor window.





    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 3, 2016 2:48 AM