locked
Connecting Emulator on Windows Server 2008 system RRS feed

  • Question

  • Hi all,

    I am facing problem while connecting the Windows Mobile PPC emulator through Windows Mobile Device Center 6.1 (64-bit).

    My system configuration is-

    OS- Windows Server Datacenter (i.e. server 2008 and which is 64-bit)

    I have installed-

    1) Visual Studio 2008

    2) Windows Mobile Device Center 6.1 (64-bit)

    Before raising this question I tried with
        -  installing "Desktop Features"
        -  enabling "Offline Files" from control panel.
        -  Making connection settings in the Device Center. (i.e. Changing Bluetooth to DMA)

    But still i am not able to connect the emulator.
    Though I am getting the Sync icon on the Home Screen of the emulator but on the Device Center the status is not connected.

    Note- I am experimenting it by accessing the above system remotely using Remote Desktop.


    Guys, please help me out.



    Thanks and Regards, Amit Rote
    • Edited by Amit Rote Tuesday, August 18, 2009 1:23 PM add
    Tuesday, August 18, 2009 12:28 PM

Answers

All replies

  • No one know the answer?

    Ok can anybody tell me which are the steps to follow while installing the Windows Mobile Development Environment on the system with OS- Windows Server Datacenter (i.e. server 2008 and which is 64-bit)?

    Guys it’s urgent, please help me out.


    Thanks and Regards, Amit Rote
    Wednesday, August 19, 2009 5:22 AM
  • Hi Amit Rote,

    Do you cradle the emulator, if not, please cradle it. Your other steps seems right, please refer to following blog which provide detailed steps to connect to emulator, if you miss some steps, please correct it and check again.
    http://blogs.msdn.com/akhune/archive/2005/11/16/493329.aspx


    Best regards,
    Guang-Ming Bian - MSFT
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, August 20, 2009 6:56 AM
    Moderator
  • Hi Guang-Ming Bian,

    Thanks for the reply.

    I checked the steps with the link. But still I am not able to connect the emulator. :( 

    However, one more doubt is that I don’t think that I need to do settings for the proxy server whatever mentioned in that link. Is it? Normally I have not done any proxy related settings while working on my system. (And I guess these are not necessary also. Please correct me if I am wrong.).


    Thanks and Regards, Amit Rote
    Thursday, August 20, 2009 7:30 AM
  • Hi Amit,

    You are right, we don't need to set proxy server if you just connect with emulator. 

    Device Emulator 2.0 is for 32-bit Activesync/WMDC, which will fails for 64-bit WMDC. So the problem should be this, the solution is to install Device emulator 3.0 for 64-bit, downlaod here:

    http://www.microsoft.com/downloads/details.aspx?familyid=A6F6ADAF-12E3-4B2F-A394-356E2C2FB114&displaylang=en


    Best regards,
    Guang-Ming Bian - MSFT




    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Monday, August 24, 2009 3:31 AM
    Moderator
  • Hello Amit, I got almost exactly the same symptom today.

    • A Windows Server 2008 R2 (x64) system.
    • VS2008 and bundled device emulator(v3) Windows Mobile emulator image.
    • Windows Mobile Device Center 6.1.6965
    • Client user(in administrator group) connect through remote desktop(RDP).
    • When RDP client cradles a emulator WM5 vm(virtual machine), the vm reports ActiveSync connected, however, WMDC reports "not connected".

    Solution: DO NOT run device emulator via RDP, just run from the "console", and WMDC will report "Connected" then you can browse WinCE files WMDC.

    BTW, when you cradle from RDP client, and if a user is logged into the console and runs WMDC, the user at console will also see WMDC report "Connected". So, WMDC behave really weird in a multi-user environment.

     

    (chjfth)


    a C/C++ programmer
    • Proposed as answer by Manoj4u Wednesday, June 27, 2012 9:56 AM
    Monday, August 8, 2011 12:44 PM
  • Hi Chen Jun

    I  had  the same  problem   and  the solution suggested by  u  worked  for  me.

    Thanks  a  lot

    Wednesday, June 27, 2012 10:00 AM
  • again, be sure that you have installed loopback adapter so your emulator works properly, if not then for sure it wont work properly

    Janitor

    Saturday, September 8, 2012 11:18 AM
  • it does not matter what is your OS just be sure that before installing VS that you have already install microsoft loopback adapter so your emulator works properly. that is very much important to install the loopback adapter

    Janitor

    • Proposed as answer by Jason Perez Saturday, September 8, 2012 11:32 AM
    Saturday, September 8, 2012 11:32 AM