locked
Property promotion won't allow me to make editable field RRS feed

  • Question

  • I'm attempting to make a field that I created in infopath 2010(using the 2007 filler form template) editable in Sharepoint 2007. But where I think the option to do that would be, I get the message "Some options are hidden when publishing to Sharepoint Portal Server 2003".

    Anyone know why I would get this message when I'm using a Sharepoint 2007 server?

    I'm trying to do this in order to set the field in my sharepoint designer 2007 workflow. But none of the fields I created in infopath Designer show up in the set field options.

    Monday, October 24, 2011 1:59 PM

Answers

  • Hi Andrew232006,

    I can see your scenario when using InfoPath 2010, as by default InfoPath 2007 is integrated well with SharePoint 2007.

    In InfoPath 2010, when going to File->Form Options->Property Promotion, it will show “Some options are hidden when publishing to SharePoint Portal Server 2003”, in InfoPath 2007, the promotion message will be “Some options are hidden, They are only available when publishing to Windows SharePoint Sevices 2007”, this is a by design prompt message in InfoPath.

    To make a field editable in SharePoint, you can choose to “Allow users to edit data in this field by using a datasheet or properties page”.

    In publishing Wizard, after creating form library for the template, it is to choose fields available as columns in SharePoint sites and Outlook folders, add the form fields you need to edit in SharePoint, in the Select a Field or Group dialog, check the options “Allow users to edit data in this field by using a datasheet or properties page”, then the field will be editable in SharePoint, and you will see it in SharePoint Designer workflow.

    Thanks,
    Qiao
    • Marked as answer by Andrew232006 Wednesday, October 26, 2011 5:31 PM
    Wednesday, October 26, 2011 6:02 AM
    Moderator

All replies

  • i have the same issue however i am using SharePoint 2010 enterprise. would love to hear a solution to this!
    Wednesday, October 26, 2011 1:57 AM
  • Hi Andrew232006,

    I can see your scenario when using InfoPath 2010, as by default InfoPath 2007 is integrated well with SharePoint 2007.

    In InfoPath 2010, when going to File->Form Options->Property Promotion, it will show “Some options are hidden when publishing to SharePoint Portal Server 2003”, in InfoPath 2007, the promotion message will be “Some options are hidden, They are only available when publishing to Windows SharePoint Sevices 2007”, this is a by design prompt message in InfoPath.

    To make a field editable in SharePoint, you can choose to “Allow users to edit data in this field by using a datasheet or properties page”.

    In publishing Wizard, after creating form library for the template, it is to choose fields available as columns in SharePoint sites and Outlook folders, add the form fields you need to edit in SharePoint, in the Select a Field or Group dialog, check the options “Allow users to edit data in this field by using a datasheet or properties page”, then the field will be editable in SharePoint, and you will see it in SharePoint Designer workflow.

    Thanks,
    Qiao
    • Marked as answer by Andrew232006 Wednesday, October 26, 2011 5:31 PM
    Wednesday, October 26, 2011 6:02 AM
    Moderator
  • It isn't very clear but what you need to do is go through the Publishing Wizard again. If you go to File, Advanced Options, Property Promotion, you do not get the option to make the field editable.

    You have to go to File, Publish, Publish to SharePoint Server and go through the wizard again. You will get to the screen in the wizard where you can set the fields to be promoted and that is where you can make the field editable.


    JD Wade
    Senior SharePoint Consultant, MCTS
    Horizons Consulting, Inc.
    Blog: http://wadingthrough.com
    Twitter: http://twitter.com/jdwade
    • Proposed as answer by Andy Bonner Monday, November 7, 2011 6:26 PM
    Friday, November 4, 2011 5:02 PM
  • Very helpful. This helped me.

    Up to now I needed always a tool like "SharePoint Manager 2010.exe" to set a specific column afterwards to readonly=false to make it editable without the form, because in SharePoint Library Column Settings the column was not editable and was greyed out. So I had to publish the form and then do always set the readonly=false to make the column beeing editable in SharePoint or beeing able to use it in a workflow. 

    Not I can succesully publish the form and the column will still be editable in SharePoint without doing any other modifycations. Thanks. This stabilizes the application und saves a lot of time.

    Wednesday, July 26, 2017 8:44 AM