locked
Error The $(TargetFrameworkVersion) RRS feed

  • Question

  • User385166 posted

    hi

    How to solve this problem The purpose of running on the version 4.3

    1>------ Build started: Project: App1.Android, Configuration: Debug Any CPU ------ 1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(819,2): warning XA0113: Google Play requires that new applications and updates must use a TargetFrameworkVersion of v8.0 (API level 26) or above. You are currently targeting v4.4 (API level 19). 1>C:\Users\Mohammad.nuget\packages\xamarin.forms\4.5.0.617\buildTransitive\Xamarin.Forms.targets(183,5): error XF005: The $(TargetFrameworkVersion) for App1.Android (v4.4) is less than the minimum required $(TargetFrameworkVersion) for Xamarin.Forms (9.0). You need to increase the $(TargetFrameworkVersion) for App1.Android. ========== Build: 0 succeeded, 1 failed, 1 up-to-date, 0 skipped ========== ========== Deploy: 0 succeeded, 0 failed, 0 skipped ==========

    Wednesday, April 22, 2020 7:04 PM

Answers

  • User382871 posted

    Please set the TargetFramework to the required version.

    Go to Android Project -> Properties -> Application, set TargetFramework to 9.0 or higer.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, April 23, 2020 1:54 AM

All replies

  • User382871 posted

    Please set the TargetFramework to the required version.

    Go to Android Project -> Properties -> Application, set TargetFramework to 9.0 or higer.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, April 23, 2020 1:54 AM
  • User385166 posted

    sample create new project blank

    run android 4.4 = ok run android 4.3 = ok run android 4.2 = ok

    sample create new project MasterDetailPage

    run android 4.4 = ok run android 4.3 = no

    Thursday, April 23, 2020 10:18 AM
  • User382871 posted

    Xamarin.Forms applications can be written for Android on Android 4.4 (API 19) or higher. Android 5.0 (API 21) is recommended as the minimum API. This ensures full compatibility with all the Android support libraries, while still targeting the majority of Android devices. Please test the project on Android 5.0 or higher.

    Tutorial: https://docs.microsoft.com/en-us/xamarin/get-started/supported-platforms?tabs=windows

    Friday, April 24, 2020 7:07 AM
  • User394162 posted

    Unless you had changed the target framework manually to use version 4.4 this might mean the latest android SDK API found in your machine is 4.4. At most cases Visual Studio is defaulted to select the latest target framework installed in your machine. To change target framework versions you can simply double-click on properties under solution explore in Visual Studio, If you do not have frameworks of higher versions you can install them by installing android SDK packages through the SDK manager.

    To access the android SDK manager go to tools => android => android sdk manager and install android SDK APIs of higher versions

    Friday, April 24, 2020 9:08 PM